1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Updating Forum Statistic Automatically

Discussion in 'XenForo Questions and Support' started by Ji2myTran, Oct 12, 2013.

  1. Ji2myTran

    Ji2myTran Active Member

    Hi Guys,

    After update my forum to Xen ver 1.2, i noticed that my forum didn't update the statistics such as total registered member, thread views,... I have to run Cron Entries manually to update all forum information :(. This is really inconvenient. Thus, i wonder if anyone know how to set the forum updates automatically or set the running time of Cron Entries same as the way you want?

    Thanks!
     
  2. Mike

    Mike XenForo Developer Staff Member

    It sounds like your cron tasks have stopped running. Upgrade to 1.2.2 if you're not running it already. Otherwise, disable and re-enable a cron task.

    You can also set the tasks to run at your preferred interval (though this will be overwritten when upgrading).
     
  3. Ji2myTran

    Ji2myTran Active Member

    Is this will fix the issue if i disable and re-enable all cron tasks, Mike?

    Thank you!
     
  4. Mike

    Mike XenForo Developer Staff Member

    If it is indeed that the crons have stopped, yes.
     
    Ji2myTran likes this.
  5. Ji2myTran

    Ji2myTran Active Member

    Thank you, Mike! ;)
     
  6. Ji2myTran

    Ji2myTran Active Member

    Hi @Mike :

    I have tried to disable and enable the Cron Entries function and delete all caches as well but seems that the forum Statistic is still doesn't updates all the changes in forum such as total views,... I really wanted to update my forum to newest version but too many add-ons had been installed, just afraid that it will affect those add-on and my style, which was design for Xen 1.2 only.

    Are there any other ways to fix this? Even adding the running Cron Entries Schedule such as after one hour, 30 mins,...?

    Thanks! :(
     
  7. Ji2myTran

    Ji2myTran Active Member

    I think i know how to fix the issue, just need to set the schedule for Cron Entries to run, thanks! ;)
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    Upgrading from a 1.2 version to the latest should be fairly painless.
     
  9. Ji2myTran

    Ji2myTran Active Member

    Still the same for Xenforo ver 1.2.2, except if you set the schedule of running time for each Cron entry
     

Share This Page