1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Uncaught exception 'ErrorException'

Discussion in 'Resolved Bug Reports' started by Greatman, Oct 24, 2011.

  1. Greatman

    Greatman Member

    Some of my members on my forum are receiving this error, doesn't really know where it come from. It looks like it's random (my member reported it does that sometimes when F5ing the page, looking at alerts and looking at his PM)

    Fatal error: Uncaught exception 'ErrorException' with message 'Undefined variable: showTrace' in /var/vhost/lebelwco/public_html/XenForo/library/XenForo/Error.php:76 Stack trace: #0 /var/vhost/lebelwco/public_html/XenForo/library/XenForo/Error.php(76): XenForo_Application::handlePhpError(8, 'Undefined varia...', '/var/vhost/lebe...', 76, Array) #1 /var/vhost/lebelwco/public_html/XenForo/library/XenForo/Application.php(295): XenForo_Error::unexpectedException(Object(Zend_Db_Adapter_Mysqli_Exception)) #2 [internal function]: XenForo_Application::handleException(Object(Zend_Db_Adapter_Mysqli_Exception)) #3 {main} thrown in /var/vhost/lebelwco/public_html/XenForo/library/XenForo/Error.php on line 76
     
  2. Kier

    Kier XenForo Developer Staff Member

    Fixed.
     
  3. Greatman

    Greatman Member

    Thanks :D
     
  4. Lone Wolf

    Lone Wolf Well-Known Member

    I'm getting this error as well. How do I fix it?

    Fatal error: Uncaught exception 'ErrorException' with message 'Undefined variable: showTrace' in /home/site/forums/library/XenForo/Error.php:76 Stack trace: #0 /home/site/forums/library/XenForo/Error.php(76): XenForo_Application::handlePhpError(8, 'Undefined varia...', '/home/site/p...', 76, Array) #1 /home/site/forums/library/XenForo/Application.php(295): XenForo_Error::unexpectedException(Object(Zend_Db_Statement_Mysqli_Exception)) #2 [internal function]: XenForo_Application::handleException(Object(Zend_Db_Statement_Mysqli_Exception)) #3 {main} thrown in /home/site/forums/library/XenForo/Error.php on line 76
     
  5. Lone Wolf

    Lone Wolf Well-Known Member

    View Page Source shows this...

    <br />
    <b>Fatal error</b>: Uncaught exception 'ErrorException' with message 'Undefined variable: showTrace' in /home/site/forums/library/XenForo/Error.php:76
    Stack trace:
    #0 /home/site/forums/library/XenForo/Error.php(76): XenForo_Application::handlePhpError(8, 'Undefined varia...', '/home/site/f...', 76, Array)
    #1 /home/site/forums/library/XenForo/Application.php(295): XenForo_Error::unexpectedException(Object(Zend_Db_Statement_Mysqli_Exception))
    #2 [internal function]: XenForo_Application::handleException(Object(Zend_Db_Statement_Mysqli_Exception))
    #3 {main}
    thrown in <b>/home/site/forums/library/XenForo/Error.php</b> on line <b>76</b><br />
     
  6. Lone Wolf

    Lone Wolf Well-Known Member

    Does anyone know how to fix this or what's wrong?
     
  7. Mike

    Mike XenForo Developer Staff Member

    If you still have that issue, you need to upgrade to the latest version. That said, this issue only happens if you have another issue as well - this will only show you the real problem.
     
  8. Lone Wolf

    Lone Wolf Well-Known Member

    Upgrading was my first idea as well but I get the same error at forums/admin.php so I cant even log into the backend to do the upgrade

    What is the other issue?
     
  9. Mike

    Mike XenForo Developer Staff Member

    This issue will be fixed by simply uploading the new files.

    The underlying issue is unknown - it's likely specific to your server. If I had to guess, there are database issues.
     
    Lone Wolf likes this.
  10. Lone Wolf

    Lone Wolf Well-Known Member

    Thanks I'll try that Mike
     
  11. Lone Wolf

    Lone Wolf Well-Known Member

    You were right it was a corrupted mysql database, they restored it from a backup
     

Share This Page