• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

unable to edit style..

Martyn

Active member
#1
always geting

Error


Security error occurred. Please press back, refresh the page, and try again.

seems like when editing the css for for width it doesnt like it!

thanks
 

Jake Bunce

XenForo moderator
Staff member
#2
I think that error means your security token expired. Did you wait a long time to submit the page after it was opened? The token can expire if you are idle on a page for too long.
 

Brogan

XenForo moderator
Staff member
#3
Please don't cross-post as it makes it difficult to keep the discussion in one place.

I have closed your other thread so we can concentrate on resolving the issue here.

Can you clarify the steps you are taking and when the error occurs?
 

Martyn

Active member
#6
when i click appearince i click style properties takes me to Master Style: Style Properties then i click general then i click Page Width Controller, i edit the width click save and

Error


Security error occurred. Please press back, refresh the page, and try again.

also get this error wthout editing even if i just click the save button.
 

Jake Bunce

XenForo moderator
Staff member
#7
Normally you don't edit the master style. The master is only available in debug mode. With that said, I just tested your instructions in the master style and I didn't get any errors.

You might try reinstalling the forum and then testing it again just to make sure it's not something you changed.
 

Martyn

Active member
#8
not changed anything =-/; at all.... only added a addon but removed that and still happens!! how can i back up the database? :( even out of debug mode.... it still happens, i was asked to do this to see the error, but nothing showed? or i dont no how to see it?
 

Brogan

XenForo moderator
Staff member
#9
If you have access to phpMyAdmin then export the database to your hard drive and then import it after reinstalling.
Make sure you check the "drop table" option or you will have to manually drop them.

db.PNG
 

Martyn

Active member
#10
Code:
Server Error

Mysqli statement execute error : Prepared statement needs to be re-prepared

   1. Zend_Db_Statement_Mysqli->_execute() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/Zend/Db/Statement.php at line 300
   2. Zend_Db_Statement->execute() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/Zend/Db/Adapter/Abstract.php at line 468
   3. Zend_Db_Adapter_Abstract->query() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/Zend/Db/Adapter/Abstract.php at line 633
   4. Zend_Db_Adapter_Abstract->delete() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/Model/CodeEvent.php at line 168
   5. XenForo_Model_CodeEvent->deleteEventsForAddOn() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/Model/CodeEvent.php at line 198
   6. XenForo_Model_CodeEvent->importEventsAddOnXml() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/Model/CodeEvent.php at line 179
   7. XenForo_Model_CodeEvent->importEventsDevelopmentXml() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/CacheRebuilder/ImportMasterData.php at line 34
   8. XenForo_CacheRebuilder_ImportMasterData->rebuild() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/ControllerHelper/CacheRebuild.php at line 26
   9. XenForo_ControllerHelper_CacheRebuild->rebuildCache() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/Install/Controller/Install.php at line 243
  10. XenForo_Install_Controller_Install->actionStep2b() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/FrontController.php at line 303
  11. XenForo_FrontController->dispatch() in /home/afk/domains/ashfordtalk.co.uk/public_html/library/XenForo/FrontController.php at line 132
  12. XenForo_FrontController->run() in /home/afk/domains/ashfordtalk.co.uk/public_html/install/index.php at line 17
getting this error when trying to reinstall? wtf?
 

Brogan

XenForo moderator
Staff member
#12
Presumably you're using the latest download from here?
I wouldn't think it's corrupt but you never know.

Who is your host or is it a local install?
 

Martyn

Active member
#16
someone suggested disabling mod security, still no joy..
Code:
RewriteCond %{HTTP_HOST} ^www\.ashfordtalk\.co.uk$
RewriteRule ^(.*)$ http://ashfordtalk.co.uk/$1 [L,R=301]
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
<IfModule mod_security.c>
    SecFilterEngine Off
</IfModule>
 

Null

Well-known member
#17
I also have this error, I'm using XenForo Beta 5.

I was trying to edit style properties, pressed 'Update Style Properties' and get "Security error occurred. Please press back, refresh the page, and try again".
 

Null

Well-known member
#19
Yeah, I'm running PHP with Suhosin (0.9.6.2), I'll use your .htaccess method (I don't see why anybody should remove Suhosin, after all... it's there for a reason).

Thank you, Jake.
 
#20
someone suggested disabling mod security, still no joy..
Code:
RewriteCond %{HTTP_HOST} ^www\.ashfordtalk\.co.uk$
RewriteRule ^(.*)$ http://ashfordtalk.co.uk/$1 [L,R=301]
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
<IfModule mod_security.c>
    SecFilterEngine Off
</IfModule>
I don't know if this is possible, but I know I for one was having problems with the .htaccess file rewrite to add www. to all pages, you may want to try changing it. I've found that so far this works perfect on my site.... can't say for sure that it's right, but it is working. You may want to give it a shot and see if you still get errors.

Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^MYSITE.com
RewriteRule (.*) http://www.MYSITE.com/$1 [L,R=301]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data|js|styles|install) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
before I changed it to this I had it set up pretty much identical to yours and continously received errors while trying to load
Code:
http://MYSITE.com
The error said something about security would not allow the page to load with the site specific settings.