XF 2.2 Ubuntu PHP 7.4 vs Compiled PHP 8.1.1 vs ondrej/php PPA Repo

atom12

New member
I'm brand new to Xenforo and trying XF 2.2.8 and Ubuntu 20.04 LTS.

I'd like to take advantage of the Ubuntu default "apt" repo and updates, meaning I'd have to go with PHP 7.4.

The security issues with compiling and applying security patches by hand to PHP 8 or relying on "ondrej" for their PHP repo isn't appealing.

Is there anything I give up with using PHP 7.4 on XF 2.2? As far as I can tell by searching, PHP 7.4 might not work with some addons... true?
 

bzcomputers

Well-known member
PHP 7.4 might not work with some addons... true?

Yes, but very few add-ons.

As far as Xenforo 2.2.8 itself everything will work fine with PHP 7.4. It will also work with PHP 8.0, but full compatibility with 8.1 is still being tested and isn't recommended to be used outside of a testing environment.
 

bzcomputers

Well-known member
I was saying there are very few add-ons that won't work on PHP 7.4. I've personally only seen one or two myself. As for PHP 8.0 I would say you will likely find a few more incompatible with PHP 8.0.
 
Top