• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Trophies

#1
For some reason i hit 30 messages and im suppost to get trophie from default when its been installed. no one and i mean NO ONE is getting their tophies and points after doing what its required to earn trophies.
 

Vincent

Well-known member
#2
For some reason i hit 30 messages and im suppost to get trophie from default when its been installed. no one and i mean NO ONE is getting their tophies and points after doing what its required to earn trophies.
Are you aware that that is controlled by cron entry that runs at specific times?
You can manually run them if you want. Admin CP -> Tools -> Cron Entries -> Update User Trophies

It's set to update every 40 minutes as default.
 
#3
so is there anyway to like make it update closes to 0 minute or 1 second ? or at least 1 minute?
because my friend posted few messages and still havnt got points. im the only one who got points
 

Jake Bunce

XenForo moderator
Staff member
#4
You can run it manually:

Admin CP -> Tools -> Cron Entries -> Update User Trophies -> Controls: Run

You can also edit the cron so it runs more frequently if you wish.
 

Vincent

Well-known member
#5
so is there anyway to like make it update closes to 0 minute or 1 second ? or at least 1 minute?
because my friend posted few messages and still havnt got points. im the only one who got points
Yes, you can edit it. When on the cron entry page, click on "Update User Trophies". There you can change it to X minutes. 1 is a possibility, but I don't recommend that. I'd say 15 minutes is more close to the minimum I'd set it if I were you.
 

Chris D

XenForo developer
Staff member
#6
You probably wouldn't want it to run that often.

The reason it isn't live and the reason it's by default at 40 minutes is because it's quite a performance intensive task.

Although on a small board every second might work fine - imagine if you had thousands of active members.

I would suggest leaving it at 40 minutes, but yeah it can be changed by going to:

Admin CP > Tools > Cron Entries > Update User Entries

and change the value in there to run at X minutes.
 

Vincent

Well-known member
#13
thanks then. but the other issue is that one of my users posted 3 messages and default , when u post the 1st message you get 1 point. he didnt get it and also another user. :/
If you set the updater to 10 mins, wait 10 minutes. If the problem continues then, please report it again here :) (Or you can Run it manually)
 

Vincent

Well-known member
#20
http://creepersaway.net is my site for the main portal page it load so long for some reason.

but this is the member page: http://creepersaway.net/index.php?members/

you can see that im the only one who has points
The only thing I could think of that's gone wrong is that you edited when the Throphies are awarded and that something went wrong there. Try doing what Jake tells you here: http://xenforo.com/community/threads/recalculate-trophy-points.30800/#post-351948