1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Timeouts, slow site

Discussion in 'Troubleshooting and Problems' started by Fleur, Mar 23, 2013.

  1. Fleur

    Fleur Member

    I use Xenforo 1.1.3, PHP 5.1.4, MariaDB (with MaxDB settings), custom-skin and use the following add-ons:
    • Custom BBCode Manager 1.3.4
    • Custom Fields by Waindigo 1.0.3
    • LiquidPro Core 1.0.1
    • LiquidPro Simple Forms 1.1.1
    • Nodes As Tabs 1.1.3
    • Post As User by Waindigo 1.0.3
    • Showcase 1.0.0 RC2
    • Simple Gallery 1.0.2
    • XFA - BBCode for tabs 1.0.3
    • [8wayRun.Com] XenCarta (Wiki) 1.3.9
    • [8wayRun.Com] XenPorta (Portal) 1.5.5

    I experience very slow loading and constant time-outs, on light site with less than 50 users.
    The time-outs are due to 1st time loading site. I have no idea why.
    I've re-installed Xenforo twice, changed hosts twice . Now I host on Xeon E3 1245v2 with SSD, 1Gb/sec bandwidth.
    What could be the issue?
  2. Slavik

    Slavik XenForo Moderator Staff Member

    PHP 5.1.4

    You should upgrade to AT LEAST 5.3, prferably 5.4.

    Does the issue occur with the addons disabled?
  3. Mike

    Mike XenForo Developer Staff Member

    It can't be 5.1.4. XF wouldn't run with that.

    But disabling add-ons and checking on a stock style. And you mentioned CloudFlare as well, so you should disable that (or go to the site without using it). You need to reduce the number of variables as much as possible.
  4. Fleur

    Fleur Member

    Typo. PHP 5.4.13 latest, MariaDB 5.5.30 instead of MySQL.

    - I've set MariaDB to huge database setting,
    - PHP to timeout in 360 seconds,
    - Xeon E3 with SSD drives

    Site loads in 1 minute. :sleep:

    I'm trying the Cloudflare replacement.
  5. andret

    andret Member

    I send you a PM
  6. Fleur

    Fleur Member

    I managed to fix. I replaced Cloudflare with Incapsula.
    CyclingTribe likes this.
  7. andret

    andret Member

  8. Fleur

    Fleur Member

    I tried turning on/off RocketLauncher, Caching (Off/Basic/Simple/Agressive), Image Caching (Off/shrink image/cache/CDN), JS Minify (On/Off), CSS Compression (On/Off), Browser Check (On/Off), CDN Delivery (On/Basic/Off). Custom page settings, Custom Rules settings to no effect.

    I tried Incapsula and asked various people on forum to check it. At least now they do not get slow site and works as claimed.

    If you are happy with Cloudflare - good for you. That's none of our business if you use Cloudflare and getting good results. We didn't get good results and tried a recommendation on this forum. At least Incapsula works.
  9. Fleur

    Fleur Member

    You can close. Changing from Cloudflare to Incapsula solved problem.

Share This Page