XF 1.2 Thread Create button is double in forum view, how can fix?

Brogan

XenForo moderator
Staff member
#5
Yes.

That is plain text with no link back to here and unless you have purchased branding free, that is a breach of the license terms and conditions.
 
#6
Yes.

That is plain text with no link back to here and unless you have purchased branding free, that is a breach of the license terms and conditions.
Check it again carefully, you will see the redirect link to Xenforo.com because i use the addon GoodForNothing Url Redirector :) So the link takes the following form:

http://forum1.vietdesigner.net/redirect/?url=http%3A%2F%2Fxenforo.com

I can't use the redirect for this link? Let me know and i will fix if this isn't accepted!

And please help me fix this problem!
 

Russ

Well-known member
#8
Check it again carefully, you will see the redirect link to Xenforo.com because i use the addon GoodForNothing Url Redirector :) So the link takes the following form:

http://forum1.vietdesigner.net/redirect/?url=http%3A%2F%2Fxenforo.com

I can't use the redirect for this link?
Default xenforo plain html:
Code:
<div id="copyright"><!--XF:branding--><a class="concealed" href="http://xenforo.com">Forum software by XenForo&trade; <span>&copy;2010-2013 XenForo Ltd.</span></a><!--/XF:branding--></div>
Yours...

Code:
<div id="copyright">Forum software by XenForo&trade; &copy;2011 XenForo Ltd.</div>
 

Brogan

XenForo moderator
Staff member
#11
That is still not acceptable.

Please remove the redirect and revert it to the original state.

I have locked this thread until you do so.

If you fail to comply, your account will be limited.
 
#15
Check for any customized template such as : forum_view or possibly thread_list

Also could be a plugin.
I don't think the reason is addon, because i try to use another style and don't see the same problem.

I try to check the template forum_view and remove the code below
Code:
<xen:if is="{$canPostThread}">
    <xen:set var="$newDiscussionButton"><a href="{xen:link 'forums/create-thread', $forum}" class="callToAction"><span>{xen:phrase post_new_thread}</span></a></xen:set>
    <xen:if is="!{$renderedNodes}">
        <xen:topctrl>{xen:raw $newDiscussionButton}</xen:topctrl>
    </xen:if>
</xen:if>
But after removed, both of the button is disappear, i only want to remove one of these double buttons :(
 
#19
I solved this problem, i add the css below to breadcrumb.css :)

Code:
.breadBoxTop .topCtrl {     display: none; }
Perfect ;)
 
Last edited:
Top