• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

The uploaded file is too large for the server to process.

Fred.

Well-known member
#1
Hi,

When I try to upload a file only (50kb) i'll get this error.
The following error occurred
The uploaded file is too large for the server to process.
Php.ini settings
Code:
;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
upload_tmp_dir = /tmp

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 64M

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20
Nginx settings
Code:
client_max_body_size 1024m;
client_body_buffer_size 128k;

server_names_hash_bucket_size 128;
server_names_hash_max_size 10240;
data directories are chmod 777

I have no Idea anymore what this can be.
Anyone else?
 

Mr. Goodie2Shoes

Well-known member
#2
What is the maximum limit for post data?
And there is a chance your server's temp folder is not writable...

Yeah, it happened to me once even with 777 permission... once I've updated my dir the error went away...
 

Fred.

Well-known member
#3
Code:
post_max_size = 64M
How can I test if /tmp is writable (from the right user)

I did
Code:
[root@server01 tmp]# nginx -t 2> text.txt
[root@server01 tmp]# ls
backup.121714           systemd-private-DObjJ1  systemd-private-lppLYH  systemd-private-sgY0yg  text.txt
systemd-private-A6TgGU  systemd-private-JbciQ3  systemd-private-M1DQC9  systemd-private-WXBsgn
[root@server01 tmp]#
They just told me it's a know CentOS 7 problem. But I can't find anything about it.