1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed The server did not respond in time. Please try again.

Discussion in 'Resolved Bug Reports' started by DroidHost, Jun 4, 2011.

  1. DroidHost

    DroidHost Well-Known Member

    when ever I try to Create new template I have this err :
    The server did not respond in time. Please try again.

    V:102
    Localhost ... my Computer
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Which software are you using for your localhost?

    You may need to tweak the settings.
     
  3. DroidHost

    DroidHost Well-Known Member

    rightnow
    I had this situation in Xampp and Wampserver ....

    also this msg :
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I use Xampp and have never had those issues.
    Do you have a lot of styles installed?
     
  5. DroidHost

    DroidHost Well-Known Member

    no new XenForo installation ... !
    I have it in the wamp so I have to test it in other app to confirm the problem !!
    I increase the execution time but .... nothing :(
     
  6. DroidHost

    DroidHost Well-Known Member

    I Found the problem ::
    The template was :
    PHP:
    <xen: if is="{$myname} == 1"><a herf="www.google.com">Google</a></if>
    And there were alot of xen template syntax err ...
    After Make them right :
    PHP:
    <xen:if is="{$myname} == 1"><a herf="www.google.com">Google</a></xen:if>
    the msg should give a correct hint ? right ?
     
  7. ragtek

    ragtek Guest

    Hm, i can confirm this!

    Instead of getting a error message,
    error2.PNG

    it's running 2 minutes(my timeout time) and then i'm getting the timeout
    error.PNG

    It's because of <xen :if
     
    DroidHost likes this.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Which template is that syntax error in?

    I've created a few new templates on my localhost in 1.0.2 and haven't encountered the problem.

    Your href is also incorrect, it's currently herf.
     
  9. ragtek

    ragtek Guest

    brogan, try to create a template with
    <xen: if is="{$myname} == 1"><a herf="www.google.com">Google</a></if>

    :p

    edit:
    grrrrrrr, i hate the editor
     
  10. ragtek

    ragtek Guest

    It's happening always if you have only <xen: without an "parameter"
     
  11. DroidHost

    DroidHost Well-Known Member

    dont look at the HTML err, sorry about that ....

    look to the xen template syntax
     
  12. Mike

    Mike XenForo Developer Staff Member

    Relatively minor issue, but I'll move this to bugs. Not sure if we can easily prevent it though.
     
  13. Mike

    Mike XenForo Developer Staff Member

    Looks like this was a bug in the parser generator. Rebuilding with the latest version seems to have sorted it. :)

    It only happened when there was an error before doParse() was every called on the parser.
     
    Vincent, ragtek and DroidHost like this.
  14. DroidHost

    DroidHost Well-Known Member

    good to know , :) keep the good work
     
    Vincent likes this.

Share This Page