1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The search could not be completed. Please try again later.

Discussion in 'Enhanced Search Support' started by RobParker, Apr 27, 2012.

  1. RobParker

    RobParker Well-Known Member

    I've just installed ES on our test site but I'm getting the following error: The search could not be completed. Please try again later.

    One thing I wanted to check, our database is on it's own server but ES is installed on our webserver (as it has more resources than our database server).

    In the XF options, I've left the server details as 127.0.0.1 which I assume is still correct?

    Any ideas?
     
  2. RobParker

    RobParker Well-Known Member

    I should include that it's definitely running:

    root@####]# /etc/init.d/elasticsearch status
    ElasticSearch is running: PID:928294, Wrapper:STARTED, Java:STARTED
     
  3. Slavik

    Slavik XenForo Moderator Staff Member

    Do you have a error in the admincp?
     
  4. RobParker

    RobParker Well-Known Member

    Rebuilding the search index seems to have fixed it. As its letting me search for two-letter words it looks likes it's working :)

    Only confusing point is that in my XF options I still have it set to a minimum of 4 letters. Does ES not respect that setting?
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

  6. RobParker

    RobParker Well-Known Member

    Yep that works but my ACP setting for Search Minimum Word Length is still set to 4...
     
  7. Slavik

    Slavik XenForo Moderator Staff Member

    It does not take the setting from acp.
     
  8. RobParker

    RobParker Well-Known Member

    Ah ok, thanks.
     
  9. RobParker

    RobParker Well-Known Member

    Next question, what's the default path to the index files if I don't specify one in the config?
     
  10. Slavik

    Slavik XenForo Moderator Staff Member

    The es installation folder
     
    RobParker likes this.

Share This Page