[TH] XenBlog

[TH] XenBlog [Paid] 1.1.0

No permission to buy ($30.00)
@Jason76

Yep, you can try ours. It leaves a lot to be desired. Its nothing like the one we had on vBulletin and is not worth the money to me. Our blog usage is WAY down from previously, only about 2% of the use I would say.

http://bushcraftusa.com/forum/blogs/
Is it possible to make the homepage or main URL to point toward the blog? For instance, MyWebsiteURL.com would be the blog when typed in. Does the software do that?
 
Is it possible to make the homepage or main URL to point toward the blog? For instance, MyWebsiteURL.com would be the blog when typed in. Does the software do that?
That is handled through your DNS server. You can get your hosting company to forward the main URL to the sub-URL directory.
 
Where can I go to look at documentation for importing vB4 blogs etc into this addon? I am looking moving my site to xF and need to have a plan for the blogs...

Thanks,
Sean
 
It would be great if it were possible to import them! I'm gone from vBulletin to XenForo and find myself in the situation of not knowing how to export the old blog. :( If there were changes I would be very happy! I bought addon. :)
 

marremp2

Active member
Hello
Few questions regarding this add-on :
1. Do you have an importer for Better Blogs ?
2. Are blogs or blog posts assigned to categories ?
3. Users can have several blogs ?
4. Is it possible to tag blog posts / blogs (not user-tagging but keywords tagging) ?
5. Do you plan to implement style customization options for users for their blog (as previously in Better Blogs) ?
Many thanks
 

Dalton Prock

Well-known member
1. Do you have an importer for Better Blogs ?
Not at this time.

2. Are blogs or blog posts assigned to categories ?
Yes, you can add unlimited categories from your ACP to allow you or your users to assign to their blogs.

3. Users can have several blogs ?
Of course, you can assign them a certain number of blogs they can post daily which is can be edited in User Group Permissions.
EDIT: This is incorrect, there is no ability to allow this at this time. Said ability refers to the number of blog posts a user has.

4. Is it possible to tag blog posts / blogs (not user-tagging but keywords tagging)?
Only users right now.

5. Do you plan to implement style customization options for users for their blog (as previously in Better Blogs) ?
We will add it to our to-do list for future updates.
 
Last edited:

Jake B.

Well-known member
3. Users can have several blogs ?
Of course, you can assign them a certain number of blogs they can post daily which is can be edited in User Group Permissions.
Just to be clear on this option, that permission refers to the number of blog posts, there is not the ability for users to create multiple blogs (John Doe's Cat Blog vs John Doe's Dolphin Blog)
 
Hello, pretty happy with the addon, but I do have one small issue.

On blog titles, when an apostrophe ( ' ) is used, upon editing or updating the blog, it will add an increasing numbers of backslashes ( \ ) behind it. I suspected it was due to the server's PHP settings and the magic quotes directives, but even after turning those directives off in a php.ini at the root of my Xenforo installation (which is also my public_html root if that matters), the issue persists.

Any advice on how to fix? My first thought was to try to use stripslashes, but I'm a novice at best on PHP and I wasn't even sure where in the addon's files I would do that in without it being in the wrong place and causing more harm.

Some help would be appreciated!
 

silence

Well-known member
Hello, pretty happy with the addon, but I do have one small issue.

On blog titles, when an apostrophe ( ' ) is used, upon editing or updating the blog, it will add an increasing numbers of backslashes ( \ ) behind it. I suspected it was due to the server's PHP settings and the magic quotes directives, but even after turning those directives off in a php.ini at the root of my Xenforo installation (which is also my public_html root if that matters), the issue persists.

Any advice on how to fix? My first thought was to try to use stripslashes, but I'm a novice at best on PHP and I wasn't even sure where in the addon's files I would do that in without it being in the wrong place and causing more harm.

Some help would be appreciated!
Just to check but does this issue happen on thread titles?
 
Just to check but does this issue happen on thread titles?
Not on thread titles, no. Or any other title fields in any other addons (such as Media gallery). It occurs only on XenBlog title fields. Included a screenshot for visuals.

It happens anytime anyone creates a Blog which includes an apostrophe in the title, and upon first saving it will display correctly. However, any edit will cause a backslash to display behind the apostrophe. A second edit two more. And so on.
 

Attachments

marremp2

Active member
Thanks a lot for your answers.
4. Is it possible to tag blog posts / blogs (not user-tagging but keywords tagging)?
Only users right now.
Do you plan to implement this feature in future updates ? This is a critical point for us in our decision making process to keep blogs or not (and migrate them into an article system).
 
Top