1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unmaintained [TH] Node Language Override by ThemeHouse 1.0.1

Override the display language for specific forums.

  1. Jon W

    Jon W Well-Known Member

    Waindigo submitted a new resource:

    Node Language Override by Waindigo (version 1.0.0) - Override the display language for specific forums.

    Read more about this resource...
     
  2. Jon W

    Jon W Well-Known Member

    Waindigo updated Node Language Override by Waindigo with a new update entry:

    Version 1.0.0a released

    Read the rest of this update entry...
     
  3. yavuz

    yavuz Well-Known Member

    After I installed the addon earlier today (havent made any changes in settings), it threw an error:

    ErrorException: Undefined index: forum - library/Waindigo/NodeLanguage/ControllerHelper/NodeLanguage.php:12

    #0 /home/user/public_html/library/Waindigo/NodeLanguage/ControllerHelper/NodeLanguage.php(12): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/user/pu...', 12, Array)
    #1 /home/user/public_html/library/Waindigo/NodeLanguage/Extend/XenForo/ControllerPublic/Forum.php(39): Waindigo_NodeLanguage_ControllerHelper_NodeLanguage->setNodeLanguage(Object(XenForo_ControllerResponse_View))
    #2 /home/user/public_html/library/Waindigo/NodeLanguage/Extend/XenForo/ControllerPublic/Forum.php(10): Waindigo_NodeLanguage_Extend_XenForo_ControllerPublic_Forum->_processNodeLanguage(Object(XenForo_ControllerResponse_View))
    #3 /home/user/public_html/library/EWRporta/ControllerPublic/Forum.php(9): Waindigo_NodeLanguage_Extend_XenForo_ControllerPublic_Forum->actionIndex()
    #4 /home/user/public_html/library/ForumWatch/Extend/ControllerPublic/Forum.php(4): EWRporta_ControllerPublic_Forum->actionIndex()
    #5 /home/user/public_html/library/XenForo/FrontController.php(310): ForumWatch_Extend_ControllerPublic_Forum->actionIndex()
    #6 /home/user/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #7 /home/user/public_html/index.php(13): XenForo_FrontController->run()
    #8 {main}
     
  4. Jon W

    Jon W Well-Known Member

    What were you doing when this error exception was thrown?
     
  5. yavuz

    yavuz Well-Known Member

    nothing, started right after i installed the addon. dont know if another user was browsing the forum
     
  6. Jon W

    Jon W Well-Known Member

    So this is on every page? Or you just see it in your error log?
     
  7. SchmitzIT

    SchmitzIT Well-Known Member

    Quick question. If I read this correctly, will this allow me to section off a forum into "English", "French", "Spanish", etc. categories, and the mod will allow me to determine the language per category/forum?
     
    rafass likes this.
  8. Jon W

    Jon W Well-Known Member

    Correct.
     
    rafass and SchmitzIT like this.
  9. Dynamic

    Dynamic Well-Known Member

    Just installed. This addon is not working for me. I am using it with the Social addon of yours. I set the language in the category and no errors are reported. However, when I visit the category it still displays in the default language. Any ideas?
     
  10. Jon W

    Jon W Well-Known Member

    Dynamic likes this.
  11. Rob

    Rob Well-Known Member

    Im reading it the same way.... but I'm also reading another use.

    You could have forum sections for books, jobs, classifieds - this will allow you to use more appropriate language in those sections.... for instance, 'post new thread', becomes 'post new job' or 'post new book'. Used in conjunction with @Waindigo's custom fields mod it brings in so much more power for customisation.
     
    Jon W likes this.
  12. Dynamic

    Dynamic Well-Known Member

    Exactly. I use social groups for both "social groups" and member "blogs" using this. You simply change the language phrases to what you like. This is simply an amazing addon, as all of Jons addons are.
     
    Jon W likes this.
  13. Jon W

    Jon W Well-Known Member

    The only barrier to using it like this is if you also allow for multiple languages. Then it gets quite complicated! But if you only have one language on your site (e.g. English), then this is a great way to use this add-on.
     
    Dynamic and Rob like this.
  14. Jon W

    Jon W Well-Known Member

  15. sami simo

    sami simo Well-Known Member

    I like the idea, is this working in 1.3? I can not see any option to override the display language ?
     
  16. Jon W

    Jon W Well-Known Member

    Works fine for me in 1.3, FYI the options are in the ACP and per forum.
     
  17. sami simo

    sami simo Well-Known Member

    Thanks Waindig, I'm facing a strange issue, once I change the language and click save, the forum return to the default language. its impossible for me to override it.
     
  18. jamalfree

    jamalfree Active Member

    i am waiting stable version.......
    thanks
     

Share This Page