1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unmaintained [TH] Moderation Queue Information by ThemeHouse 1.0.0b

Adds the ability to view the IP, register date and message count of users with moderated content.

  1. Jon W

    Jon W Well-Known Member

    Waindigo submitted a new resource:

    Moderation Queue Information by Waindigo - Adds the ability to view the IP, register date and message count of users with moderated content.

    Read more about this resource...
     
    Last edited: Sep 21, 2013
    arms likes this.
  2. Jon W

    Jon W Well-Known Member

    Adam Howard likes this.
  3. Stuart Wright

    Stuart Wright Well-Known Member

  4. Jon W

    Jon W Well-Known Member

    Yes. It will be caused by this add-on conflicting with another add-on -- so in your case it looks like this add-on was conflicting with the Show Similar Threads add-on.
     
  5. RoldanLT

    RoldanLT Well-Known Member

    Feature request:
    Please add a new function to include what forum section or thread does the message posted?
     
  6. z3r010

    z3r010 Member

    I just came to ask this myself.

    Any chance of it being added?
     
  7. Dubbed Navigator

    Dubbed Navigator Active Member

    Are any template modifications needed if using a non standard one?

    I cant see this feature when installed, and have added myself to the moderator usergroup to see if it made a difference
     
  8. Jon W

    Jon W Well-Known Member

    Might be. Best thing to do is to check with the Default Style first.

    Are you using XenForo 1.2?
     
  9. Dubbed Navigator

    Dubbed Navigator Active Member

    Thanks for the reply.
    Yes im on 1.2

    Think I may have sussed it. My moderators can see it, and I can see in your code that it looks for the user bwing being a moderator. Is it possible that its seeing im an administrator and not displaying it even though im in both usergroups?

    If so, could the code be edited to allow for administrators as well?
     
  10. Jon W

    Jon W Well-Known Member

    I thought you had to be a moderator to view the moderation queue -- even if you are also an administrator.
     
  11. Dubbed Navigator

    Dubbed Navigator Active Member

    Yes i have figured it now and it is as above. Seems a bit skew to me that you have so many ways to select someone as a moderator (in profile etc) but it only actually works this way
     
  12. Jon W

    Jon W Well-Known Member

    That's just the way XenForo works unfortunately. You will have to raise it with the XenForo developers.

    Glad you got it sorted though.
     
  13. Dubbed Navigator

    Dubbed Navigator Active Member

    Its no biggy, once i have it figured out and everyone set as they should be there wont be an issue. Teaches me for setting people up the Vbulletin way!

    You produce some fantastic stuff by the way, good on you!
     
    Jon W likes this.
  14. Stuart Wright

    Stuart Wright Well-Known Member

    I think there might be an issue with this in 1.3.
    I'm seeing 0.0.0.0 as the IP address.
    temp1.jpg
    Also Jon could I request a quote to add the country name of the IP under the IP address (if GeoIP is installed) and add a Spam button to decimate the user is the viewer has permission to use the Spam button?
     
  15. Neso

    Neso Member

    I confirm also problem with IP ... also how do you have option: Forum ... I installed this addon but do not see that ?
     
  16. Jon W

    Jon W Well-Known Member

    Stuart Wright likes this.
  17. Neso

    Neso Member

  18. Jon W

    Jon W Well-Known Member

    Please drop me a PM to discuss contributing to this.
     
  19. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    dude u messed something up i think

    i get this when i import and after rebuild templates:

    [​IMG]

    Code:
    ErrorException: Fatal Error: syntax error, unexpected end of file, expecting function (T_FUNCTION) - library/Waindigo/Listener/LoadClass/20140604.php:247
    Generated By: Unknown Account, 3 minutes ago
    Stack Trace
    
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(40) "http://portalcentric.net/forums/members/"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    
    Code:
    ErrorException: Fatal Error: syntax error, unexpected end of file, expecting function (T_FUNCTION) - library/Waindigo/Listener/LoadClass/20140604.php:247
    Generated By: Unknown Account, 4 minutes ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(56) "http://www.portalcentric.net/forums/index.php?liveupdate"
    ["_GET"] => array(1) {
    ["liveupdate"] => string(0) ""
    }
    ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(16) "/forums/shoutbox"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
    }
    }
    
    
    Code:
    ErrorException: Fatal Error: Class 'Waindigo_Listener_InitDependencies' not found - library/Waindigo/AdminStyles/Listener/InitDependencies.php:4
    Generated By: Unknown Account, 4 minutes ago
    Stack Trace
    
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(52) "http://portalcentric.net/forums/index.php?liveupdate"
      ["_GET"] => array(1) {
        ["liveupdate"] => string(0) ""
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(17) "/forums/shoutbox/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
    
     
  20. |Jordan|

    |Jordan| Active Member

    Is this compatible with XF 1.4.1 ?
     

Share This Page