1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Style Property Bug

Discussion in 'Styling and Customization Questions' started by Zephyr, Apr 17, 2013.

  1. Zephyr

    Zephyr Well-Known Member

    Hello, I have a bug with my new style for custom arrow in breadcrumb :

    Configuration :

    [​IMG]

    Render :

    [​IMG]

    Here it's ok.
    But if I define that (image remplace color) :

    [​IMG]

    I have :

    [​IMG]

    And if I remove the border color :

    [​IMG]

    I have :

    [​IMG]

    How use an image for custom the arrow background please ? Thanks.
     
  2. Steve F

    Steve F Well-Known Member

  3. EQnoble

    EQnoble Well-Known Member

    Item Arrow, Inner

    Image: path/to/your/image; - Position: 0 center;
    Border-right: Clear value
    Item Arrow, Outer

    Border-right: Clear value



    Let me know if that works for you.
     
  4. Zephyr

    Zephyr Well-Known Member

    Hello, thanks but I have found a nice methode for generate arrow in css ! :)

    http://cssarrowplease.com

    User rgba(); property for change opacity and remplace .arrow_box by div #id or .class :)

    [​IMG]
     
  5. EQnoble

    EQnoble Well-Known Member

    One problem is that rgba isn't supported in ie8
     
  6. Zephyr

    Zephyr Well-Known Member

    Too bad for IE, must move with the times, this browser is still lagging...
     
  7. EQnoble

    EQnoble Well-Known Member

    But it comes with windows 7, and some people cannot upgrade because of the environment they view xenforo pages from such as work.
     
  8. Zephyr

    Zephyr Well-Known Member

    Arf :S
    I will test your solution.
     
  9. Chris D

    Chris D XenForo Developer Staff Member

    Use the rgba colour. XF automatically converts it to use the rgba.php helper
     
    Zephyr and EQnoble like this.
  10. EQnoble

    EQnoble Well-Known Member

    You don't have to do anything you don't want to do, I was just offering a solution above because I tried it and it worked and I had a minute and it would have be shiesty not to share it.

    I am merely saying that you will lose a portion of your audience if you do a lot by that methodology and for anyone following along that does it that doesn't really test ie8 properly, they may unknowingly be turning away ie users who can't really see the entirety of the page if many modification are made ignoring ie completely until MS comes to the age of reason with their browser

    Now that only works with colors applied directly in the style properties correct?


    If I wanted to invoke that helper elsewhere like in another template how would I go about that...or is not possible?
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    Works anywhere IIRC. Just put the normal rgba CSS reference and XenForo handles the rest during compile I think. Been a while since I tested it.

    Just like you only need to do border-radius and XenForo renders all of the various browser prefixed attributed e.g moz-border-radius etc.
     
    Zephyr likes this.
  12. Zephyr

    Zephyr Well-Known Member

    Ho, thanks ! :)
     
  13. EQnoble

    EQnoble Well-Known Member

    I have an example with a style I started that I can show you...anything in extra.css using rgba was not converted in any way and did not display at all in <= ie8 ...

    Also I thought that in Zephyr's example he is implying that he wants transparency so those stars (as I would have to guess they are) behind the breadcrumb kind of show through though I could be wrong...
     
  14. Zephyr

    Zephyr Well-Known Member

    @EQnoble, Good render (use my code with rgba) :

    [​IMG]

    Work with IE :)

    [​IMG]

    Not look breadcrumb, no finish ^^
     
  15. EQnoble

    EQnoble Well-Known Member

    Yes they work...but your breadcrumbs are no longer transparent in ie
     

Share This Page