• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed  Strange space added above quote

Floren

Well-known member
#1
I created a new reply and post it.
Then, I decided to add the user quote and edited the reply, by pasting the quote code.
It inserted a large space above the quote.
 
F

Floris

Guest
#2
Ah, I thought it was just me, it's on my list to report. But haven't gotten around to it yet. Since you see it too, hereby I post my finding; confirmed :D
 

Shamil

Well-known member
#3
For the record, here's the source code.



<div class="messageContent">
<blockquote class="messageText ugc baseHtml"><span style="font-size: medium"><span style="font-family: 'Times New Roman'"> </span></span><br />
<span style="font-family: 'Times New Roman'"> </span><br />
<span style="font-family: 'Times New Roman'">

<div class="bbCodeBlock bbCodeQuote">

<div class="attribution type">borbole said:

<a href="goto/post?id=5498#post-5498" class="AttributionLink">&uarr;</a>

</div>

<blockquote>I did not mean to imply that js is a bad thing or anything like that. I meant that in my opinion was a little overused, that is all <img src="styles/default/foro/smilies/smile.png" class="smilie" alt=":)" /></blockquote>
</div></span><br />
Still waiting to tell me why you think is overused. <img src="styles/default/foro/smilies/smile.png" class="smilie" alt=":)" /></blockquote>



</div>

It looks like some line breaks, br, have been added.
 

Erik

Well-known member
#4
Yeah, it's what happens when there's a line break between the BB code tag and the start of the content. For instance:
Code:
Code:
[quote]
... content ...
[/quote]
Produces:
... content ...
While:
Code:
[quote]... content ...
[/quote]
Produces:
... content ...
 

Mike

XenForo developer
Staff member
#5
This issue should generally be fixed now. Though it can probably still come up, I believe it should be less frequent.