1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum is for release discussion only. Discussions that do not relate specifically to the resource release should be discussed in another, more appropriate forum.
    Dismiss Notice
  3. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Start Conversation Link to Profile Page (Left Side)

Discussion in 'Template Modifications [Archive]' started by Tilkißey, Jan 1, 2011.

  1. Tilkißey

    Tilkißey Well-Known Member

    Hi all,
    you can look for explaining to attached image file

    instructions

    open member_view template and FIND
    HTML:
    <dd><a href="{xen:link 'members/trophies', $user}" class="OverlayTrigger">{xen:number $user.trophy_points}</a></dd>
    add BELOW
    HTML:
    <xen:if is="{$canStartConversation}"><dd><a href="{xen:link 'conversations/add', '', 'to={$user.username}'}"><input type="submit" class="button primary" value="{xen:phrase start_conversation}" /></a></dd></xen:if>

    and save the template =)

    if you dont want to add button (you want only text), you have to use these codes
    HTML:
    <xen:if is="{$canStartConversation}"><dd><a href="{xen:link 'conversations/add', '', 'to={$user.username}'}">{xen:phrase start_conversation}</a></dd></xen:if>
    regards...
     

    Attached Files:

    • ss.jpg
      ss.jpg
      File size:
      110.4 KB
      Views:
      104
  2. ddmmh

    ddmmh Well-Known Member

    Ive noticed this is lacking a button for this.

    This mod should be deafult, nice work!
     
    Digital Doctor, zaiger and Puntocom like this.
  3. ddmmh

    ddmmh Well-Known Member

    Works perfectly!
     
    Tilkißey likes this.
  4. gmaister22

    gmaister22 Active Member

    Agreed.
     
    Tilkißey and ddmmh like this.
  5. ddmmh

    ddmmh Well-Known Member

    Ill see if Brogan agrees.
     
    Tilkißey likes this.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Anyone is free to post any suggestion for what they think should be in the core.

    It's up to the developers whether they include it or not :)
     
    Tilkißey likes this.
  7. ddmmh

    ddmmh Well-Known Member

  8. Kaiser

    Kaiser Well-Known Member

    Thanks so much! Very helpful.
     
  9. Tilkißey

    Tilkißey Well-Known Member

    updated and added permission check with xen:if (coz i was forgot :( )
     
  10. erich37

    erich37 Well-Known Member

    this button is missing in XF-default.......
     
  11. Brendon Meynell

    Brendon Meynell Active Member

    thanks - it's fantastic and easily added :)
     
  12. Morgain

    Morgain Well-Known Member

    +1 thank you - lovely easy edit. Important addition.
     
  13. Morgain

    Morgain Well-Known Member

  14. zaiger

    zaiger Active Member

    I still to this day will open a member's profile page when trying to send them a CM, now I won't feel stupid! Thanks a lot!
     
  15. Floris

    Floris Guest

    Starting a conversation from the profile is already possible, btw. It's under the Information tab.
    Screen shot 2011-11-07 at 5.27.43 AM.png

    Thanks TB for this template mod btw, thumbsup.
     
    zaiger likes this.
  16. zaiger

    zaiger Active Member

    Oh now I feel even worse :X3:
     
  17. Floris

    Floris Guest

    Fuhrmann likes this.
  18. Morgain

    Morgain Well-Known Member

    Oh dear this worked beautifully in my test install. But on my new 1.0 live install the button does not show.

    On member_view my code is like this:
    Code:
    <dd><a href="{xen:link 'members/trophies', $user}" class="OverlayTrigger">{xen:number $user.trophy_points}</a></dd>
    <!-- ADD BUTTON ON LEFT -->
    <xen:if is="{$canStartConversation}"><dd><a href="{xen:link 'conversations/add', '', 'to={$user.username}'}"><input type="submit" class="button primary" value="{xen:phrase start_conversation}" /></a></dd></xen:if>
    
    Have compared with my test install template and it looks identical.
    But the test install has the button and the new 1.1 does not.
     

Share This Page