1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Skimlinks JS Browser Issues in Opera/IE7

Discussion in 'Troubleshooting and Problems' started by Cooper, Oct 16, 2011.

  1. Cooper

    Cooper Active Member

    I have an issue in Opera, users were complaining that the WYSIWYG quick reply was not loading. [edit] This seems to be caused by the presence of the skimlinks JS.

    Note reply box isn't there and "Tweet" is there but no facebook Like button. Also stuck at "Element 35/35" in address bar above.

    Now this isn't working on my edited style, but it is working properly on the xF default style. I haven't that many edited templates so am having trouble tracking down the differences in code/templates. Any ideas?

    Don't really want to take the default xF style and start to reskin it if I can avoid it!

  2. Brogan

    Brogan XenForo Moderator Staff Member

    That screenshot also shows that JavaScript hasn't loaded properly.

    Are you on shared hosting?
    Is it a particularly slow server?

    All you can do is look at any edited templates which may be related, such as the post and share templates. Then revert them one at a time to see if it resolves it.
    Then reapply your edits once again after determining what the issue was and correcting it.
  3. Cooper

    Cooper Active Member

    No a relatively quick dedicated box here. No issues in other browsers.
  4. Cooper

    Cooper Active Member

    Update - the issue is with the skimlinks JS. Seeing if there is a workaround. Certainly removing the code from the template allows a full page load in Opera.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Good to know, thanks for updating the thread.
  6. Cooper

    Cooper Active Member

    The only workaround I can think of is putting a browser detect line in and dropping the JS load for the opera browser - help with that appreciated! Also contacted skimlinks re the issue, will post up any findings.
  7. trilogy33

    trilogy33 Well-Known Member

    Confirmed here too and my report on the issue went in a few minutes ago.
    I wrote about it here as occuring on all styles with no changes made to my install:
    Not an XF bug, definitely a service issue. (y) Happens across all browsers, which of course it would.
    They've (SL) had one similar service issue in the past IIRC reported in their News column to advise their users, which made me remember it.
    Cooper likes this.
  8. Cooper

    Cooper Active Member

    Update on this, no response from Skimlinks yet its with their tech team. However this also effects IE7 - crashes the browser when the skimlinks js is included at the bottom of page_containter_js_body

    We didn't have these issues pre 1.1 beta, and it effects two browsers (Opera and IE7) so any thoughts on what has changed and what may effect it/workarounds appreciated.
  9. trilogy33

    trilogy33 Well-Known Member

    Not that it makes any difference, but mine's in the footer template, the very last line and after the </xen:hook>
    I'm on XF 1.0.4 and recently the loading graphic had improved in Firefox 7.1 - with IE8 and IE7 showing no loading graphic at all, when just tested this very second.
  10. Cooper

    Cooper Active Member

    Yea putting it at end of footer doesn't make any difference :(
  11. trilogy33

    trilogy33 Well-Known Member

    If it's causing major upset on your board, one route to consider is to pull the script out of the template, or comment it out for the time being until the situation calms.
    Other than that and if by doing the above you'd be looking at a significant revenue loss, is to try a different script in the meantime; Viglink for example.
  12. Cooper

    Cooper Active Member

    Not really an option - need a fix! Maybe skimlinks themselves will propose a solution.
  13. Cooper

    Cooper Active Member

    Good news - skimlinks have resolved this issue today. Beta testing FTW!
  14. trilogy33

    trilogy33 Well-Known Member

    Big wait on skimlinks resolves, so much so that it's non operable. :(
    I'm showing up to 6.57 seconds for one to complete. It's been over a week now.
    Joining the EveryFeed API google group serves up no responses, Oct 17th.
  15. Cooper

    Cooper Active Member

    IE7 issue returned :(

    Logged with Skimlinks.
  16. jauburn

    jauburn Well-Known Member

    Was just hunting down the source of a "white quick reply box" issue (normally on my board it's dark). Turns out this was cause by skimlinks js at the bottom of page_containter_js_body. Is that the correct location for that script?

    In any case, I had to remove the skimlinks js. Issue was primarily in IE 9.
  17. Cooper

    Cooper Active Member

    I haven't had any issues with skimlinks since start of Nov across all major browsers (IE7-9, chrome, FF, Safari, Opera)
  18. DBA

    DBA Well-Known Member

    Just narrowed this issue down to Skimlinks, can you guys also confirm?
  19. graham_w

    graham_w Active Member

    I'm having users report the same "please enter a valid message" when posting with IE and i'm using skimlinks also.

    I'll investigate further.
  20. graham_w

    graham_w Active Member

    I was able to recreate the issue on my board using IE9, and when I removed skimlinks the error went away.

    However, I setup a vanilla Xenforo install and added skimlinks, it worked fine.

    Still going through this to figure it out ...

    FYI - if your users are reporting the "please enter valid message" error, I could not recreate the error until I changed the following settings in IE9.

    Make sure the 3 settings marked below in IE were as per the screen shot


    * Uncheck "Disable script debugging (Internet Explorer)"
    * Uncheck "Disable script debugging (Other)"
    * Check "Display a notification about every script error"

    and then when I was logged in to the forum and viewing a thread, the error

    Line: 283
    Error: Object doesn't support property or method 'context'

    popped up. Then I typed a message in quick reply and tried to post it and I got the error "Please enter a valid message" and it wouldn't post.

    I've disabled all plugins on my main board and this issue still exists.

    Hope this helps someone else in trying to sort this out.

Share This Page