XF 2.2 Share this post icon missing

FTL

Well-known member
The share this post / share this thread icon is missing, as per the screenshot below. Note that I've blanked out the rest of the URL for privacy; this isn't how it looks.

I've looked around the ACP, but can't figure out what's causing it.

This started happening after:
  • the site URL was changed
  • a new theme was added. This happens with all themes, even the one that XF came with

I don't know if it was just one of those that caused it, both, or maybe something else.

This happens in the latest 227 patch 1 version. The development version running locally on my PC still works ok.

Solutions gratefully accepted. 🙂


Missing icons.PNG
 
Solution
That's a good point, I didn't think to try a different browser: works fine in Chrome and Edge.

I've just realized what it is: the ad blocker in Firefox. 🤦‍♂️ My site carries no ads at the moment, so I turned it off on the old site, but of course, it came back on when I switched URLs, but had forgotten all about it. Turning it off again fixed the problem. 🙂

Brogan

XenForo moderator
Staff member
I checked the URL against your license and the icons are showing fine for me in the default and custom styles.

Is it related to a different site/URL?
 
  • Like
Reactions: FTL

FTL

Well-known member
That's a good point, I didn't think to try a different browser: works fine in Chrome and Edge.

I've just realized what it is: the ad blocker in Firefox. 🤦‍♂️ My site carries no ads at the moment, so I turned it off on the old site, but of course, it came back on when I switched URLs, but had forgotten all about it. Turning it off again fixed the problem. 🙂
 
Solution

Brogan

XenForo moderator
Staff member
Huh! Interesting that FF ad blocker blocks those.

I use uBlock and they show, which is what I would expect as they're not ad related.

You can leave the blocker enabled and just whitelist your site.
 

FTL

Well-known member
Yeah, it's ad block plus on mine. Been thinking for ages that there must be better blockers out there, but never got round to trying different ones. I've got it switched off for this site, too.

I feel like a right numpty now for missing it, lol.
 
Top