1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server error when trying to create new language

Discussion in 'XenForo Questions and Support' started by Been Told, Oct 7, 2010.

  1. Been Told

    Been Told Well-Known Member

    As you can see in this video, when I try to add a language, XF tells me there was a server error.
    Does anyone experience this too? Or even better, where can I see what kind of error was thrown?
     
  2. Blandt

    Blandt Well-Known Member

    your server log?
     
  3. Been Told

    Been Told Well-Known Member

    Oh ok, I thought maybe XF keeps an error log too.
     
  4. Been Told

    Been Told Well-Known Member

    Ok here is the error log entry:
    Code:
    [Thu Oct 07 23:16:36 2010] [error] [client xx.xx.xx.xx] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/vhosts/domain.tld/httpdocs/xf/index.pl 
    I take it I need to enable FollowSymLinks or SymLinksIfOwnerMatch. I've enabled both in the httpd config file and reloaded Apache, but that didn't change anything.
     
  5. Been Told

    Been Told Well-Known Member

    Any more ideas anyone?
     
  6. Blandt

    Blandt Well-Known Member

    Thu Oct 07 23:16:36 2010] [error] [client xx.xx.xx.xx] Options FollowSymLinks or SymLinksIfOwnerMatch
    is off which implies that RewriteRule directive is forbidden: /var/www/vhosts/domain.tld/httpdocs/xf/index.pl


    Why is it index.pl ?
    I suggest you delete your domain from apache and re-install it again with the proper sym. links
     
  7. Been Told

    Been Told Well-Known Member

    There is no index.pl in the xf folder. Deleting the domain isn't an option as the domain was created using Plesk and there's to other sites on it. So I can delete and re-add the domain without causing major disturbance.
     
    Blandt likes this.
  8. Blandt

    Blandt Well-Known Member

    but that's what the error says ..../xf/index.pl

    Yes.. do that, delete and then ad the domain again.
    I never used Plesk. Do you have ssh access ?
     
  9. Been Told

    Been Told Well-Known Member

    Yeah I do have ssh access the problem is, I don't want to delete the whole domain. Because that removes the database, the files and so on. I would have to then re-upload everything and one of the sites on that domain is a big-ish forum. Downtime isn't an option.
    So I guess I'll just use another domain and play around with that.
     
  10. Blandt

    Blandt Well-Known Member

    No you don't have to delete anything.

    You need to remove the domain from apache sites-available / sites enabled

    hmmm wait I'm getting ahead of myself here, When do you get that error and where?
     
  11. Been Told

    Been Told Well-Known Member

    I get the error when I try to add a new language in the ACP. Well the error I get is "Server Error" and nothing else. You can see it in the video.
    The error message is from the error log file.

    As for changing stuff in apache - I don't think I should do that when Plesk is running the Apache server. I don't want to mess that up.
    I've just recently bought a new iMac which I'll install MAMP on. So I'll install XF on that and then I'll be able to do whatever I want on it. I'll post again here then.
     
    Blandt likes this.
  12. Been Told

    Been Told Well-Known Member

    Ok, I have just set up MAMP and installed XF. The error does not occur.

    Mike & Kier if you see this, could you perhaps advise on what exactly I should to sort this out on my live server? I don't want to mess with Apache on a server administered by Plesk.
     

Share This Page