• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Server Error Occurred Problem

#1
i got a error when people try joining my site can you please help me fix this error


Error Message :

Code:
Official StateOFMods Forum - Error
A server error occurred. Please try again later.
how do i fix this

i tryed cleaning the Xf_Session table and tryed Repairing it but nothing it s only happens when people try signing up
 

Mike

XenForo developer
Staff member
#6
You have an add-on that added a uuid field to some table (a user-related one I suspect) and they didn't set a default value for it (which is wrong for add-ons). You'll likely either need to re-enable the add-on or remove it. In the longer term, you can speak to the author who may be able to fix it.
 

Chris D

XenForo developer
Staff member
#8
Have you uninstalled or disabled any add-ons recently?

That looks like there is an add-on that has changed the database.

It's possible that it's this one:
http://xenforo.com/community/resources/minecraft-uuid-name-change-handler.2924/

Does that seem familiar?

The quickest and best solution right now is to either enable the add-on if it is installed, or if you have removed it then reinstall it.

If it IS that add-on that caused it, then running this database query should work:

Code:
ALTER TABLE `xf_user` CHANGE COLUMN `uuid` `uuid` CHAR(32) NULL DEFAULT NULL ;
 

Chris D

XenForo developer
Staff member
#12
I spent time writing a post that asked at least two questions. Which one were you answering "no" to?

Let me ask a more open ended question:

Can you tell me exactly what add-ons you currently have (enabled or disabled) and also can you tell me which add-ons you may have uninstalled recently?
 

Chris D

XenForo developer
Staff member
#14