• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Server Error after Upgrade

Andrej

Well-known member
#1
I have helped a few users with upgrades to the latest version, and after upgrading Blueprint4Love forum there are those messages over the whole forum, including Admin CP:

Mysqli prepare error: Unknown column 'forum.node_id' in 'on clause'
Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Model/Forum.php at line 29
XenForo_Model_Forum->getForumById() in XenForo/ControllerAdmin/Forum.php at line 31
XenForo_ControllerAdmin_Forum->actionEdit() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /home/corefree/public_html/admin.php at line 13
I was able to upgrade my own forums and other forums without problems. I tried disabling all add-ons but that didn't help much.
 

Mike

XenForo developer
Staff member
#5
You'd basically have to restore from a backup. There's no reason that should have happened unless it was (accidentally?) manually removed.
 

Andrej

Well-known member
#7
You'd basically have to restore from a backup. There's no reason that should have happened unless it was (accidentally?) manually removed.
I have not touched the database at all, I just performed the upgrade, that is really weird. I see about restoring a backup..
 

borbole

Well-known member
#9
Yes, made a back up right before (now let's hope I did that right). :D
After you restore the backup, you should run the upgrader again seeing that your files are from the lastest version. That is so the database can be brought up to date with the files.

I forgot to note that it was a upgrade from 1.1 Beta 3 to Release Candidate 1.
An upgrade shouldn''t remove any db columns or anything else for that matter. Did you get any error/s during the upgrade process?

P.s. Can you try to recreate the missing column and see if that would help?
 

Andrej

Well-known member
#10
An upgrade shouldn''t remove any db columns or anything else for that matter. Did you get any error/s during the upgrade process?

P.s. Can you try to recreate the missing column and see if that would help?
Nope, no errors at all. I never touched the database until the point of this error. But we are now trying to restore a full backup, so we run the upgrade process again once we get everything restored prior to the problems. :)