XF 1.1 Server Clock Times Messed UP, can't post on threads.

faeronsayn

Well-known member
#1
On some threads I cannot post, I guess its because they are made in October 31st and its only october 30th where I am.

I've just switched servers, so that might be the reason...

this is the error I am getting on some of the threads...

Code:
The following error occurred:
Cannot insert a message in the middle of a discussion.
[LIST=1]
[*]XenForo_DataWriter_DiscussionMessage->_setPosition() in XenForo/DataWriter/DiscussionMessage.php at line 327
[*]XenForo_DataWriter_DiscussionMessage->_preSave() in XenForo/DataWriter.php at line 1414
[*]XenForo_DataWriter->preSave() in XenForo/ControllerPublic/Thread.php at line 480
[*]XenForo_ControllerPublic_Thread->actionAddReply() in XfRu/MergeDoubleUserPost/ControllerPublic/Thread.php at line 49
[*]XfRu_MergeDoubleUserPost_ControllerPublic_Thread->actionAddReply() in XenForo/FrontController.php at line 310
[*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
[*]XenForo_FrontController->run() in /home/shadygam/public_html/index.php at line 13
[/LIST]
Should I rebuild post counters / Position ... or maybe rebuild the thread information?
Would that help, or what should I do ?
 

faeronsayn

Well-known member
#4
Is the server time on the new server set correctly?
What do you mean by correctly?

I have WHM ... and in there I can set the server time.

I've set it to Canada/Atlantic , but there is an option to

so i am not sure...

Whats happening right now is that there is a post for october 31st 12:11 AM ... i think thats the latest one, on that thread I cannot post, since its only October 30th 1:13 PM.

Not sure how to fix that...?
 

Dodgeboard

Well-known member
#7
So does this mean that during time-change, there's an hour where users cannot post replies to a thread? (US changes clocks next week, is why I'm asking)
 
Top