1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Separate installs changing each others styles

Discussion in 'Troubleshooting and Problems' started by Renada, Aug 3, 2011.

  1. Renada

    Renada Active Member

    Hi,

    I've installed a test copy, fresh installation, to check different add-ons so that I can customise them. When I change a style on my test copy it changes it on the live copy too.

    The test copy has a totally blank forum, nothing imported from the live copy, it's in a separate database and as far as I can see the only link is that they're both on the same server.

    Any ideas please?

    Regards,
    Renada :)
     
  2. Digital Doctor

    Digital Doctor Well-Known Member

    Total guess: cache problem ? Would clearing your cache help ?
     
  3. Renada

    Renada Active Member

    Hi :)

    Do you mean browser cache?
     
  4. Digital Doctor

    Digital Doctor Well-Known Member

    Yea.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What kind of change? A template change?

    It certainly sounds like the two forums are sharing a database or something. Either that or the two forums are getting confused somehow (e.g. maybe you are accessing or viewing a different forum than you think).
     
  6. Renada

    Renada Active Member

    I was viewing one forum in FireFox and the other in Internet Explorer. I couldn't confuse the forums because one is live and has data and the test one has only the main forum that's installed by default.

    I added a style to which I wanted to make a few colour changes to make it easier to see but when changing from the default style to the new one it was also changing the live forum.

    Could my host company have done anything that would confuse the databases like that as both forums are installed into separate databases?

    I'm going to delete and reinstall the test forum and see if its still happening.

    Thanks to both of you for your help :)

    Regards,
    Renada
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    So if you select a different style then it affects both forums? And in separate browsers...

    I can't think of any explanation for that assuming the two forums are separate. I would be inclined to gather URLs and logins to test the problem. You can submit a ticket:

    http://xenforo.com/customers/support
     
  8. Digital Doctor

    Digital Doctor Well-Known Member

    Renada: you should try the universal cure all for most computer things: Reboot ! :)
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Check the config.php files are pointing to different databases.

    If they are then I don't see how your actions on the test installation can affect the live site.
     
  10. Renada

    Renada Active Member

    Last night I wished I could - hosted server. Seems to not be doing it now so maybe the thunderstorm rebooted it for them. LOL

    Fingers crossed :)
     
  11. Renada

    Renada Active Member

    Yep both pointing to the correct databases but as above, it appears to have righted itself *touch wood*.

    Brogan, while I have you here, is there a way to do a XenForo to XenForo import? I want to import some of the old database but not all of it so I don't want to just dump the whole thing into the new one.

    Regards,
    Renada :)
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Not at the moment.

    You would need to export from XenForo to e.g. vB or IPB and then import back to XenForo.

    Even then, partial import isn't possible, it's all or nothing.
     
  13. Renada

    Renada Active Member

    Eeeek! :(

    What would happen if I saved all the user tables as an sql and all the forums/messages tables as another and just imported those? Am I on a good hiding to nothing with that?
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    All of the tables are inter-related so manually importing them that way would just result in a broken forum.
     
  15. Renada

    Renada Active Member

    I thought that was going to be the answer :( Not to worry, I'll work on the old one instead.

    Thanks everyone for your help :)

    Regards,
    Renada
     

Share This Page