1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SEO Tips | Search Engine Optimization Tips For Your Site

Discussion in 'Forum Showcase and Critiques' started by Axis, Oct 8, 2016.

  1. Axis

    Axis Member

    Most of you may know the URL...I have seen it around for awhile and thought to myself I would love that domain name for myself. So as I purchased it awhile back I had put on Wordpress and vBulletin.
    After some problems with switching hosts and whatnot, I had to think on this before doing. I removed the Wordpress and vBulletin and converted it over to XenForo and now I have the UI.X on there and have made some customize changes to it...also have added the portal for there.

    http://seotips4.com working on getting SSL added to this. Come and join help get this place going again.
  2. IlPerazzi

    IlPerazzi Member

    Just a heads up that this site is, at least for me, taking an eternity to load. And I have a very fast connection. In the off chance you were not aware, I thought I'd drop a note.
  3. Axis

    Axis Member

    Thanks for the feedback.
  4. Lucas

    Lucas Well-Known Member

    Same for me, the site loads incredibly slow. Barely able to load anything. Wasn't able to get into the forums area.
  5. Amin Sabet

    Amin Sabet Well-Known Member

  6. Axis

    Axis Member

    I'll be working on it this week.
  7. Donny

    Donny Active Member

    It's UI.X that does that. It sucks. I installed it on two forums of mine and removed it from them both after 5 or 6 weeks.

    The features aren't worth the hassle and poor support. At one point the developers wanted me to get a new forum user having issues to plug their iPad into the computer and go into development mode on it and run a report to get some JavaScript issue sorted.

    You can't expect forum owners to need to do that let alone their members!

    Couldn't get a refund. Never touched their stuff since.

    Set your style to default and disable their plugins and it'll load instantly as XF does.
  8. Mr Lucky

    Mr Lucky Well-Known Member

    It seems a bit odd that you have a tutorial thread:


    But each tutorial is a separate post,e.g like a reply in the thread. There is some good stuff in there, but I would make each separate tutorial a resource. It also looks like some have been through a text editor and lost some formatting (headings and bullet points)

    I also find it incredibly slow (not good for an SEO site!) a search took about 8 seconds. My advice would also be go back to the default style and work from that.

    I found the dropdowns slightly confusing as the header of the dropdown (e.g. "Resources" is the same size as the links underneath, so you think it is a link but nothing happens when you click on it. Of course we know that you need to click on the main tab, but I think that would confuse users) In the default style, the dropdown header is much larger, so obviously just a header and not another link.
  9. Axis

    Axis Member

    Yeah, I had it on vBulletin and then my site ended up messing up and now it's on XF... I have added a new style to the site and hope that it fixes the problem with loading removing all of UI.X from it.

Share This Page