1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Sending email

Discussion in 'Troubleshooting and Problems' started by gavpeds, Jan 27, 2014.

  1. gavpeds

    gavpeds Active Member

    Hi all,

    So when i send an email to all users on the forum which is about 1700 i get the below error.

    Oddly though i get the email i sent fine (Test account) which is setup with the forum email.

    Server Error Log
    Error Info
    Zend_Mail_Transport_Exception: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
    Generated By: XXX, 5 minutes ago
    Stack Trace
    #0 /home/XXX/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 /home/XXX/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 /home/XXX/public_html/library/XenForo/ControllerAdmin/User.php(998): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 /home/XXX/public_html/library/XenForo/ControllerAdmin/User.php(921): XenForo_ControllerAdmin_User->_sendEmail(Array, Array, Object(Zend_Mail_Transport_Sendmail))
    #4 /home/XXX/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_User->actionEmailSend()
    #5 /home/XXX/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /home/XXX/public_html/admin.php(13): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
    ["url"] => string(60) "http://XXXco.uk/admin.php?users/email-send"
    ["_GET"] => array(1) {
    ["users/email-send"] => string(0) ""
    ["_POST"] => array(10) {
    ["page"] => string(2) "33"
    ["criteria"] => string(94) "{"user_state":["valid","email_confirm"],"is_banned":["0"],"custom_exact":{"cleaningmethod":1}}"
    ["total"] => string(4) "1769"
    ["from_name"] => string(31) "XXX"
    ["from_email"] => string(31) "XXX"
    ["email_title"] => string(27) "We have installed Tapatalk!"
    ["email_format"] => string(4) "text"
    ["email_body"] => string(607) "Hey {name},

    We have recently installed functionality for the Tapatalk App! This is a fantastic app which enables you to use the forum via the app. The great thing about this is you get push notifications! Not just an email or an on site notification but a real push notification to your phone as things happen like a reply to your post or a post you get tagged in or new messages. This is a great app that will enable you to keep up to date with the forum and be more involved with the community as a whole! Find out more here. http://XXX.co.uk/threads/tapatalk-has-now-been-added.11323/"
    ["_xfConfirm"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is a very generic error. Since you are using the default PHP mail server you would have to contact your web host to check the mail configuration in PHP and pull the mail logs. Or you can specify your own SMTP server if you have one available:

    Admin CP -> Home -> Options -> Email Options -> Email Transport Method

Share This Page