1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Running into import issue

Discussion in 'Installation, Upgrade, and Import Support' started by tmb, Aug 6, 2011.

  1. tmb

    tmb Active Member

    Finished importing into vB and now hit validate in xen to begin that process and got this:


    Server Error

    Undefined index: attachfile
    1. XenForo_Application::handlePhpError() in XenForo/Importer/vBulletin.php at line 48
    2. XenForo_Importer_vBulletin->configure() in XenForo/ControllerAdmin/Import.php at line 56
    3. XenForo_ControllerAdmin_Import->actionConfig() in XenForo/FrontController.php at line 310
    4. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    5. XenForo_FrontController->run() in /home/admin/domains/the-mainboard.com/public_html/admin.php at line 13
    Any ideas on this? Hoping not to have to remain closed for too long.
     
  2. Saarbruecken

    Saarbruecken Active Member

    I had the same problem before, the attachment table was apparently flagged broken (source database), I repaired it and had to start the import process again, then it finally made it.
     
  3. Mike

    Mike XenForo Developer Staff Member

    That would happen if there are missing settings in vB, related to whether attachments are stored as files. I don't know of any reason for this, unless you're not upgrading with a supported version.
     
  4. tmb

    tmb Active Member

    I didn't even choose to import attachments, should I maybe hit that and see if it helps?
     
  5. Saarbruecken

    Saarbruecken Active Member

    You should run all import steps.
     
  6. tmb

    tmb Active Member

    All import steps run and still same error. Looks like I'll have to put off importing yet again. Weird the test import didn't encounter this error.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What version of vB are you importing from? As Mike said, the "attachfile" setting appears to be missing from the vB database.

    Run this query on the vB database to make sure that setting exists:

    Code:
    SELECT *
    FROM setting
    WHERE varname = 'attachfile';
    
    This should return one record.
     
  8. tmb

    tmb Active Member

    Yeah that table does not exist. Am I going to have to start completely from scratch then?
     
  9. Luke F

    Luke F Well-Known Member

    Your entire settings table doesn't exist?

    Are you using a table prefix?
     
  10. tmb

    tmb Active Member

    Sorry I spaced, its been a long day. Table exists but there are no records for it.
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Sounds like an incomplete database. You can import the default settings but something tells me there is more missing than just settings. If you can give me access to phpmyadmin or a copy of the database then I can take a look.
     
  12. tmb

    tmb Active Member

    It was an issue with the settings table. I imported a new settings table and it fixed it. Thanks for the help everyone.
     

Share This Page