1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 RSS Feeds on forumlist not working

Discussion in 'Troubleshooting and Problems' started by melbo, Jul 1, 2012.

  1. melbo

    melbo Well-Known Member

    So I just recently converted from vB 3.8.7 and am working through some small issues as a result. A member mentioned that my RSS feed buttons next to each forum return empty results:

    Any ideas on where to start tracking this down?

    Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    For that error I am going to suggest some standard troubleshooting steps.

    1) Disable all addons.

    2) Run a file check:

    Admin CP -> Tools -> File Health Check

    Re-upload the files if any errors are reported.
     
  3. melbo

    melbo Well-Known Member

    Disabled all addons
    Ran file health check and All 1,121 checked files are present and correct.

    This is a new install. Is there anything in ACP that needs to be turned on for this to work?
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Nope.

    Unfortunately the error message isn't very helpful so we are left to guess. Is there anything in the log?

    Admin CP -> Tools -> Server Error Log

    Or the logs on your server?
     
  5. melbo

    melbo Well-Known Member

    Nothing in the logs. Just empty RSS feeds.
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Contact your host or server person to see if they can find anything in the server logs for those "index.rss" requests. The server is dropping the connection for some reason.
     
  7. melbo

    melbo Well-Known Member

    Will do. Thanks Jake
     
  8. X_Plaza

    X_Plaza Active Member

    I thinks problem at your forum link. Config that in Basic Board Information
     
    hkda_vietnam likes this.
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's possible. I have seen an invalid board URL cause errors with the RSS feed, but that normally gives a different error. It doesn't hurt to check though:

    Admin CP -> Home -> Options -> Basic Board Information -> Board URL
     
  10. melbo

    melbo Well-Known Member

    Thanks. The board info is correct http://www.mydomain.com

    We did move move the vB forum from /forum/ to / when we migrated and we had a few issues with our redirects and vBSEO rewrites. I'm not sure if we got it working by brute force or by the correct method but this may be a further complication. Had a LOT to do in the past few days post-migration so this hasn't been a top priority yet.
     
  11. melbo

    melbo Well-Known Member

    I think this must be a caching issue or a PHP 5.4 issue. It works for a small period of time after an Apache restart and then starts to fail. I've also noticed another problem that follows this similar patter. Users cannot save a new email address in their profile.

    Server is at max debug and it's still not showing anything useful. Perhaps the error is suppressed?
     
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Same error?
     
  13. melbo

    melbo Well-Known Member

    No error displayed but the timeframe is the same. After an Apache restart, this email change returns "Changes Saved" overlay. After awhile, both the RSS and the email change fail (Actually, the email change just does nothing and a refresh displays the old settings) We're seeing some PID #### segafult errors in the server logs but nothing that specifically gives a clue about this.

    I just disabled all add-ons, restarted Apache and am still running fine 1 hour later. I'm going to give it another hour and see if anything begins to fail and then start re-enabling add-ons one at a time with around an hour in between.
     
  14. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Hmm... memory problems.

    What process?
     
  15. melbo

    melbo Well-Known Member

    I'll have to check although we have 16GB of memory - much of which is just filled up with general server cache.
     
  16. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It is more likely a faulty piece of software, like a misbehaving PHP extension, and not a lack of memory.
     
  17. melbo

    melbo Well-Known Member

    My thought too. I'm slowly re-enabling add-ons and so far, so good. Unfortunately, this leaves one of my members most coveted add-on's suspect.
     
  18. melbo

    melbo Well-Known Member

    I think I finally found it:

    RSS feeds were failing
    Member Profile updates were failing
    New registrations were receiving the 324 (empty Response) upon submitting their registration.

    In apc.ini,
    I increased apc max_file_size from 1M to 5M and restarted Apache.
    So far, all three of the above have been fully functional. We'll see what it looks like 24 hours from now.

    Are most people here running APC with default settings or do we have an XF tuned apc.ini floating around here somewhere?
     
    MattW likes this.
  19. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    A segfault isn't a lack of memory. It's a process that is violating it's memory space. If APC was out of memory it should result in poor cache performance, not segfaults. The question remains, what process is attributed to that segfault error?
     
    Adam Howard likes this.
  20. melbo

    melbo Well-Known Member

    Yeah, problem came back again...
    child pid 4907 exit signal Segmentation fault (11)

    PID# changes on each occurance. I'm guessing that child is an apache server that's not exiting properly?
     

Share This Page