1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug RSS Feeder giving error on every feed I try to setup

Discussion in 'Resolved Bug Reports' started by CyclingTribe, Jan 26, 2012.

  1. CyclingTribe

    CyclingTribe Well-Known Member

    XF v1.1.1 - I'm trying to inject some jobs threads into a forum at GeeksChat but every feed I've tried has produced this same error from the feeder when I preview the feed:

    Code:
    There was a problem requesting the feed. 
    
    Error message: Feed failed to load, got response code 403
    
    Here are the ones I've tried (all work okay in my web browser):

    http://www.jobdig.com/jobs/All_Regions/Computers_-_IT/listing.xml
    http://www.jobs.ac.uk/jobs/computing/?format=rss
    http://ww2.prospects.ac.uk/rss/imvac_M.rss
    http://www.jenrickcpi.co.uk/media/rss/jobs.xml
    http://www.devbistro.com/rss/latest-jobs
    http://jobsearch.monstergulf.com/category/rss_jobs.html?cat=22

    Any idea what's going wrong?

    Cheers,
    Shaun :D
     
  2. Daniel Thomann

    Daniel Thomann Active Member

  3. CyclingTribe

    CyclingTribe Well-Known Member

    Thanks. It's the fact that they're all failing that's bugging me.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Does our feed from here work? http://xenforo.com/community/forums/-/index.rss

    If not, I wonder if there's some sort of network/proxy type of issue. The 403 is a forbidden error, so it's hard to know what end is causing this from just that response code.
     
  5. CyclingTribe

    CyclingTribe Well-Known Member

    Actually, I've just realised I had the Shorewall firewall installed recently - it's possibly related to that. I'll have a play with switching it on/off to see if RSS works. If so, I'll add a new rule.

    RSS uses port 80 doesn't it?
     
  6. Mike

    Mike XenForo Developer Staff Member

    HTTP is port 80, HTTPS is 443. By default - you don't need to run servers on particular ports, but that likely wouldn't come up.
     
  7. CyclingTribe

    CyclingTribe Well-Known Member

    Quick tip for budding geeks - don't remotely turn Shorewall off - otherwise it's a support call to the server centre to get them to restart it for you ... and in the meantime no one can get at your web sites. DOH! :ROFLMAO:

    Use the "clear" command instead to disable the rules, but not Shorewall itself ... (y)
     
  8. CyclingTribe

    CyclingTribe Well-Known Member

    Confirmed as my Shorewall firewall - apologies for the bug report.

    Cheers,
    Shaun :D
     

Share This Page