1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Route with the name 'library'

Discussion in 'XenForo Questions and Support' started by Uniphix, May 12, 2012.

  1. Uniphix

    Uniphix Active Member

  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You could cheat and change the name of the route:


    Or you can play with the .htaccess files to make it work.

    1) Edit the .htaccess file in your forum root. Add the red code:

    #	Mod_security can interfere with uploading of content such as attachments. If you
    #	cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #	SecFilterEngine Off
    #	SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	#	If you are having problems with the rewrite rules, remove the "#" from the
    	#	line that begins "RewriteBase" below. You will also have to change the path
    	#	of the rewrite to reflect the path to your XenForo installation.
    	#RewriteBase /xenforo
    	#	This line may be needed to enable WebDAV editing with PHP as a CGI.
    	#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    	RewriteRule ^library - [S=2]
    	RewriteCond %{REQUEST_FILENAME} -f [OR]
    	RewriteCond %{REQUEST_FILENAME} -l [OR]
    	RewriteCond %{REQUEST_FILENAME} -d
    	RewriteRule ^.*$ - [NC,L]
    	RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    	RewriteRule ^.*$ index.php [NC,L]
    2) Remove the .htaccess file in the library directory.

    That should make it so requests to /library are now handled as a route.
    Uniphix likes this.
  3. Uniphix

    Uniphix Active Member

    Perfect!!! Thank you

Share This Page