• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Resource Category User View Permissions [Paid] 1.0.1

No permission to buy ($9.00)

Dan

Well-known member
#1
ExtraLicense submitted a new resource:

Resource Category User View Permissions - This addon allows you to choose to which usergroups a resource category is visible to.

Resource Category User View Permissions
by ExtraLicense

This addon allows you to choose to which usergroups a resource category is visible to.

How does it work?
In every Resource Category you can select which groups have access to that category. It looks like this in the ACP:
View attachment 43939

Installation Instructions:
This addon is...
Read more about this resource...
 
#2
Code:
Server Error
 
Undefined index: category_visible_to
 
XenForo_Application::handlePhpError() in MoreRmPermissions/Extend/XenResource/Model/Category.php at line 18
MoreRmPermissions_Extend_XenResource_Model_Category->canViewCategory() in XenResource/Model/Resource.php at line 714
XenResource_Model_Resource->canViewResourceAndContainer() in XenResource/Model/Resource.php at line 616
XenResource_Model_Resource->filterUnviewableResources() in XenResource/ControllerPublic/Resource.php at line 609
XenResource_ControllerPublic_Resource->_getResourceViewWrapper() in XenResource/ControllerPublic/Resource.php at line 811
XenResource_ControllerPublic_Resource->actionView() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /XXXXXXX/index.php at line 13
 

Dan

Well-known member
#3
Code:
Server Error
 
Undefined index: category_visible_to
 
XenForo_Application::handlePhpError() in MoreRmPermissions/Extend/XenResource/Model/Category.php at line 18
MoreRmPermissions_Extend_XenResource_Model_Category->canViewCategory() in XenResource/Model/Resource.php at line 714
XenResource_Model_Resource->canViewResourceAndContainer() in XenResource/Model/Resource.php at line 616
XenResource_Model_Resource->filterUnviewableResources() in XenResource/ControllerPublic/Resource.php at line 609
XenResource_ControllerPublic_Resource->_getResourceViewWrapper() in XenResource/ControllerPublic/Resource.php at line 811
XenResource_ControllerPublic_Resource->actionView() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /XXXXXXX/index.php at line 13
I can't reproduce this.

Sure that you installed this addon? When does the error appear?
 

CFodder

Well-known member
#8
Downloaded it, installed it, no problem with it - very nice little addon that does exactly what it says.

As a future update I wouldn't mind the option, if possible, to not display a category in the list - similar to the option you can use for nodes.

Keep up the great work :).
 
#9
I can't get it to work. It installs fine, then I moved existing categories under a new category which should only be visible to usergroup A. But when I test permissions from within the admin panel with a user not having usergroup A, I still see both the resources and the categories.

Am I doing something wrong?
 

Dan

Well-known member
#10
I can't get it to work. It installs fine, then I moved existing categories under a new category which should only be visible to usergroup A. But when I test permissions from within the admin panel with a user not having usergroup A, I still see both the resources and the categories.

Am I doing something wrong?
Please do the following:
  1. Without changing anything, just save all the categories again. This way the categories will rebuild. This is a known issue and can be read in the readme file.
  2. If the problem still persists after step 1, please just try it with a test account.
 
#11
Okay, using a real test user, it works. But that is not very practical (loggin in and out, changing group permissions in between...). Is this considered a bug?
Thanks for now, I can move on...
 

Dan

Well-known member
#12
Okay, using a real test user, it works. But that is not very practical (loggin in and out, changing group permissions in between...). Is this considered a bug?
Thanks for now, I can move on...
This must be a bug in the XenForo Test Permissions feature I guess.
If it works with a real test user, it will work good :)
 

WCFA

Active member
#17
Does this work on 1.4.5 ? I would like an addon like this but unsure its still supported has not been updated in along time.
 

WCFA

Active member
#19
Hmm was not aware, but you are correct, I just installed resources, not sure how one implements the prefixes
in core. But sure a little reading I'll figure it out . Thanks Dan for pointing this out.