1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 [RESOLVED] Email Problems

Discussion in 'Troubleshooting and Problems' started by DJ-Bigboss, Jun 1, 2014.

  1. DJ-Bigboss

    DJ-Bigboss Member

    Hey guys,

    I have cPanel Hosting, however, my emails are with Resellerclub to IP protection (essentially to stop skiddies trying to DOS me).

    Now, when configuring the emails, it seems to be failing. Can you shed some light? If needed, I can submit a ticket with FTP etc, so you can look into it.

    Error Info
    Zend_Mail_Protocol_Exception: Email to andy@chitterbyte.com failed: 5.7.1 <andy@chitterbyte.com>: Sender address rejected: not owned by user mailings@chitterbyte.com -library/Zend/Mail/Protocol/Abstract.php:431
    Generated By: Andy, 2 minutes ago

    Stack Trace
    #0 /home/chitterb/public_html/library/Zend/Mail/Protocol/Smtp.php(289): Zend_Mail_Protocol_Abstract->_expect(Array, 300)
    #1 /home/chitterb/public_html/library/Zend/Mail/Transport/Smtp.php(211): Zend_Mail_Protocol_Smtp->rcpt('andy@chitterbyt...')
    #2 /home/chitterb/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #3 /home/chitterb/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #4 /home/chitterb/public_html/library/XenForo/ControllerAdmin/User.php(1029): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #5 /home/chitterb/public_html/library/XenForo/ControllerAdmin/User.php(922): XenForo_ControllerAdmin_User->_sendEmail(Array, Array, Object(Zend_Mail_Transport_Smtp))
    #6 /home/chitterb/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_User->actionEmailSend()
    #7 /home/chitterb/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #8 /home/chitterb/public_html/admin.php(13): XenForo_FrontController->run()
    #9 {main}

    Request State
    array(3) {
    ["url"] => string(53) "http://www.chitterbyte.com/admin.php?users/email-send"
    ["_GET"] => array(1) {
    ["users/email-send"] => string(0) ""
    ["_POST"] => array(10) {
    ["test"] => string(15) "Send Test Email"
    ["criteria"] => string(132) "{"receive_admin_email":"1","user_state":["valid"],"is_banned":["0"],"custom_exact":{"sexual_orientation":1,"relationship_status":1}}"
    ["total"] => string(2) "17"
    ["from_name"] => string(28) "Chitterbyte Community Forums"
    ["from_email"] => string(24) "mailings@chitterbyte.com"
    ["email_title"] => string(7) "Test Email"
    ["email_format"] => string(4) "text"
    ["email_body"] => string(24) "Hi this is a test!"
    ["_xfConfirm"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
  2. Tracy Perry

    Tracy Perry Well-Known Member

    The email address you are sending from does not match the email you are logging in with is the typical cause of that error (if you are using the SMTP email feature).
    DJ-Bigboss likes this.
  3. DJ-Bigboss

    DJ-Bigboss Member

    It's wierd as that's all correctly setup :S
  4. Tracy Perry

    Tracy Perry Well-Known Member

    So your smtp user settings is mailings@chitterbyte.com and that is also who the email shows from (configured in the ACP)?
    DJ-Bigboss likes this.
  5. DJ-Bigboss

    DJ-Bigboss Member

    Yup see below.

  6. Tracy Perry

    Tracy Perry Well-Known Member

    I don't know if it will effect it (I use postfix myself) but try removing the bounced email address.
    If that doesn't work you need to get with the smtp provider and see if they can find the error in their mailer log.
    DJ-Bigboss likes this.
  7. DJ-Bigboss

    DJ-Bigboss Member

    Confusing, but worked... meh at least it's working now! Thanks a billion for you're help!
    Tracy Perry likes this.

Share This Page