1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Registered feeds - connection refused - error 111

Discussion in 'Troubleshooting and Problems' started by Andy Larkins, Apr 16, 2012.

  1. Andy Larkins

    Andy Larkins Member

    I'm having trouble setting up the Registered feed function. My forum is attached to a wordpress site and I would like to use my wordpress rss feeds to announce new articles in the forum.

    The error Im getting is:

    Error message: Unable to Connect to tcp://www.cincysoftball.com:80. Error #111: Connection refused.
     
  2. Andy Larkins

    Andy Larkins Member

    So, the feed system works. I brought in an outside feed, no problem so this must be an issue where you cant get your own feed to post.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What is the URL of the feed? I can test it.
     
  4. Andy Larkins

    Andy Larkins Member

  5. Teddy Scott

    Teddy Scott Active Member

    Glad you posted this thread.. So instead of starting a new one, ill use this one too if ya don't mind.
    I am clicking on any of the small RSS index.rss feed icons in the forum I get this error:
    Fatal error: main() [function.require]: Failed opening required 'Zend/Feed/Writer/Renderer/Entry/Atom/Deleted.php' (include_path='/home/boss302/public_html/library:.:.:/usr/lib/php:/usr/local/lib/php') in /home/boss302/public_html/library/Zend/Feed/Writer/Renderer/Feed/Atom.php on line 132
    I have tried reinstalling from backup the atom.php, and the rss.php, and the abstract.php... still get the same error.. Is this file related, or a database related issue? also my twitter feed stopped working.. are they related to each other? How to fix?
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It's working for me. I just entered this URL as a registered feed on my forum. The connection is successful. The posts come through.

    If it's not working for you then the host must be blocking your request for some reason.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is a missing file or perhaps bad file permissions. Try uploading the original files.
     
  8. Andy Larkins

    Andy Larkins Member


    Were looking at that but I think its wordpress related myself. Opened a ticket there too. Was hoping someone had see it before.
     
  9. Teddy Scott

    Teddy Scott Active Member

    which original files?? The entire zend directory? I checked the permissions on zend and it is 755
     
  10. mrGTB

    mrGTB Well-Known Member

  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yes, upload all of the files for good measure, including the zend directory.

    Depending your server configuration, PHP files are usually 644 and directories are usually 755. If there is a permission problem it might be with a subdirectory, not necessarily the parent directory.
     
  12. Teddy Scott

    Teddy Scott Active Member


    Ill try re uploading the zend directory and its included files and check permissions. Im not sure what you mean by "all" files. You are not talking about the entire Xenforo package files including the install directory are you?
    Sorry.. Hard to communicate on internet some times..
     
  13. Teddy Scott

    Teddy Scott Active Member

    re uploaded zen directory, 755.... click on any rss feed icon on the forums page:
    Fatal error: main() [function.require]: Failed opening required 'Zend/Feed/Writer/Renderer/Entry/Atom/Deleted.php' (include_path='/home/boss302/public_html/library:.:.:/usr/lib/php:/usr/local/lib/php') in /home/boss302/public_html/library/Zend/Feed/Writer/Renderer/Feed/Atom.php on line 132
     
  14. Teddy Scott

    Teddy Scott Active Member

    hang tight on mine.. I think its WS-FTP not uploading all the files... Im using File Zilla atm...
    Ill post back thanks..
     
  15. Teddy Scott

    Teddy Scott Active Member

    :D
    problem fixed...
    It was the ftp program....
    File Zilla worked....
    Only problem with file zilla as I have seen it get carried away once or twice....
    you have to really be careful with file zilla...

    but its fine now.. preciate the help!
    This is a "feed" of frequently changing content on this site.
    You can subscribe to this feed to receive updates when this content changes.
    http://www.boss-302.com/index.php?forums/daily-ford-mustang-news.62/index.rss
    works flawlessly!
     
  16. Andy Larkins

    Andy Larkins Member

    TTT on the wordpress - XF RSS connection issue
     
  17. Andy Larkins

    Andy Larkins Member

    TTT on the wordpress - XF RSS connection issue..
     
  18. Chris D

    Chris D XenForo Developer Staff Member

    What?
     
  19. Andy Larkins

    Andy Larkins Member

    I'm having trouble setting up the Registered feed function. My forum is attached to a wordpress site and I would like to use my wordpress rss feeds to announce new articles in the forum.

    The error Im getting is:

    Error message: Unable to Connect to tcp://www.cincysoftball.com:80. Error #111: Connection refused.

    The feed system works. I brought in an outside feed, no problem so this must be an issue where you cant get your own feed to post.
     
  20. Chris D

    Chris D XenForo Developer Staff Member

    EDIT: I see this is discussing the same problem you mentioned before...
     

Share This Page