1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Redirect not working

Discussion in 'Troubleshooting and Problems' started by Laurentius, Jul 28, 2012.

  1. Laurentius

    Laurentius Active Member

    I have moved my forum from the root to a folder: /forum , to make place for a wordpress installation in the root.

    My problem now is that I can't redirect: domain.com/forum --> www.domain.com/forum
    This worked before when the forum was in the root.

    thanks
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Add the red code to XF's .htaccess file (which is in the /forum directory):

    Code:
    #	Mod_security can interfere with uploading of content such as attachments. If you
    #	cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #	SecFilterEngine Off
    #	SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    
    	RewriteCond %{HTTP_HOST} !^www\.yoursite\.com$
    	RewriteRule ^(.*)$ http://www.yoursite.com/forum/$1 [R=301,L]
    
    	#	If you are having problems with the rewrite rules, remove the "#" from the
    	#	line that begins "RewriteBase" below. You will also have to change the path
    	#	of the rewrite to reflect the path to your XenForo installation.
    	#RewriteBase /xenforo
    
    	#	This line may be needed to enable WebDAV editing with PHP as a CGI.
    	#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    	RewriteCond %{REQUEST_FILENAME} -f [OR]
    	RewriteCond %{REQUEST_FILENAME} -l [OR]
    	RewriteCond %{REQUEST_FILENAME} -d
    	RewriteRule ^.*$ - [NC,L]
    	RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    	RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
     
  3. Laurentius

    Laurentius Active Member

    Awesome! Thank you very much Jake! :)
     

Share This Page