1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Random Permission Error

Discussion in 'Troubleshooting and Problems' started by Divvens, Oct 18, 2013.

  1. Divvens

    Divvens Well-Known Member


    I seem to have a weird problem coming up. One of my members informed me that they cannot access any part of my site all of a sudden (note, it worked fine just 10 minutes back) they get a error regarding permission on ALL pages of the forum.


    I checked the permissions for the user, everything seems fine. They can also see the board while not logged in. I ran the permission analyzer and it seems to give me a report that the permissions are fine.


    So what exactly is the problem here? When I use the "Test Permissions" tool for that user even I get the same error everywhere.
    Last edited: Oct 18, 2013
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Disable add-ons and test again.
  3. Divvens

    Divvens Well-Known Member

    @Jeremy @Brogan
    I disabled all add-ons, tried, same thing. Even via the "test permissions" tool, after disabling add-ons its the same issue.
  4. Divvens

    Divvens Well-Known Member

    There's no errors in the logs, and no apparent reason that I can think off. Only happening with one user, and it's kinda confusing me. Disabling add-ons didn't help, tried it twice.
  5. arms

    arms Active Member

    Can you list your active addons as we have this error happen but think it may be down to a particular addon
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have you possibly added user permissions on the user?
  7. Digital Doctor

    Digital Doctor Well-Known Member

    Even parts that guests can see ?
    Ask the member to reboot / try another browser ?
    Flush the browser cache ?
  8. Divvens

    Divvens Well-Known Member

    Custom BBCode Manager1.3.4
    Double Post1.0.7
    Nodes As Tabs1.2.1
    Shared - RPG Features1.1.1
    Sitemap for XenForo1.3.2
    [bd] Widget Framework2.4.1

    No, the user is part of default primary group and a set of secondary groups. Users with the same user-groups as this member have everything going fine, it is only this one member that's facing this issue. The permissions analyzer says all is fine as well so its kind of confusing >.<

    The member tried with another browser, and with his mobile as well, but the error exists on both platforms. Yes, he gets the error to even part unregistered/guests can see. All pages practically (like when board is closed you get board close message on all pages, here he gets the error message on any and all pages).
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have you discouraged the user? Are you certain there are no user permissions on the user?
  10. Divvens

    Divvens Well-Known Member

    The user isn't discouraged, there aren't any discipline actions playing a role (warnings, ban, discourage). No Ip's discourage, no Ip's banned.

    And there are no user permissions on the user;

    The problem started occurring randomly, it was all fine when the user visited last time (now around 45 minutes back)
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    Has his IP recently changed? Have you discouraged or banned an IPs recently?
  12. Divvens

    Divvens Well-Known Member

    The IP of the user did change, it changes quite a bit.

    No IP's have been discourage or banned recently. There were a set of discouraged IP's (not at all near the users IP range) but I also removed all those IP's from the discouraged list. Ran the cron tools, and the problem still exists.
  13. Divvens

    Divvens Well-Known Member

    I seem to have sorted this problem out @Jeremy

    @arms maybe this may help you too.

    I went to all my usergroup permissions and set "view node" "view" as "YES"

    After that, it seems that the issue is solved. The user no more gets a permission error. However as my screenshots posted above show, the permissions already were YES and the analyzer also confirms this. But for some reason (not add-on related, as add-ons were disabled on multiple occasions and the problem continued occurring) the permissions were not all okay.

    I thought the xenForo permissions were handled differently? I.E, I could have let it be on the default if the "primary" group had "view node" and "view" permissions?
  14. Divvens

    Divvens Well-Known Member

    And now I'm paranoid, if this happens with permissions for other areas, like posting, liking, user profile etc? It'd kill forum activity without me as an admin knowing. This is scary, and I can guarantee no add-on playing a role, all add-ons I was running was disabled multiple times but the problem still existed.

    Should I go and set each userggroup permissions manually now?
  15. Brogan

    Brogan XenForo Moderator Staff Member

    It's possible that an add-on caused the issue.

    I have never encountered random permission errors of this type on multiple installation for the past three years.
  16. Divvens

    Divvens Well-Known Member

    It's possible to be an add-on, but when all are disabled the problems still persists.

    From what @arms and @Eoj Nawoh have posted on the other thread, it seems all three of us having the problem are running Widget Framework, Nodes As Tabs and Sitemap for xenForo in common (and not disabled during the problem for Eoj).

    Hmm, how do we figure out for sure its and add-on and not the which one?
  17. Jeremy

    Jeremy XenForo Moderator Staff Member

    If an add-on modifies permissions in the database, disabling them won't revert their changes.
    Amaury likes this.
  18. Divvens

    Divvens Well-Known Member

    Well if its permissions we are taking about, I think Widget Frameworks and Nodes As tabs both have permissions, not so sure about Sitemap but that doesn't play with user side permissions I think.

    Maybe @Jake Bunce or @xfrocks could help figure out the issue of this problem? The other thread related to a same random permission error is - http://xenforo.com/community/threads/permissions-error-need-help-desperate.60914/

    Maybe I should also update those add-ons to their latest versions (I'm one version behind).

    @arms and @Eoj Nawoh, what version of Nodes as Tabs, Sitemap and Widget Frameworks are you running? Because I notice this is the three add-ons common between us who have come across this issue.
  19. arms

    arms Active Member

    I'm not using Nodes as Tabs, Sitemap = 1.3.2 and widgets framework = 2.4.2.
    The error we get hasn't happened since I disabled the Steam Auth addon a few days ago.

    If your user keeps clicking on the forum nav menu. Does he get there in the end. That how our error was showing, but if you clicked 3 or 4 times, it''d load to the forum screen.
  20. Divvens

    Divvens Well-Known Member

    Hmm I see, for my user he just returned after a while and had this problem occurring and refreshing/clicking didn't take it away.

Share This Page