• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Problem with user upgrades

AndreaMarucci

Well-known member
#1
Since now when a user pay the fee via PayPal, the forum upgrade him to another usergroup with more privileges.

Since now...

Now the user pay, I see the payment on paypal but his usergroup remain the same and I've to upgrade him manually.

Please note that I've not installed any new addon in the meantime, just upgraded some addons I've installed. This is the addons list. I'd appreciate any help since I really don't know where to look and what to do...

Screenshot 04-2456023 alle 10.34.15.png
 

Jake Bunce

XenForo moderator
Staff member
#2
Check the xf_user_upgrade_log table. Is there any record of the transaction? The record may contain a specific error message if there was a problem. If there is no record of the transaction then make sure the payment completed (in your paypal account). Also check these things:

1) Make sure your board URL is correct:

Admin CP -> Home -> Options -> Basic Board Information -> Board URL

2) Note that the paypal callbacks don't work if your forum is behind a htaccess login.
 

AndreaMarucci

Well-known member
#3
Check the xf_user_upgrade_log table.
Thanks Jake, the table is full of "Payment received, upgraded/extended" but the dates are something like "1332530317". I've seen the last record, I think it's the more recent.

The URL is correct like before and I don't use htaccess for the forum, just for the admin side but I've always used it since the beginning...

But I've checked the transaction id and since I receive an email for every transaction I've seen that all the latest ID are not in the database like if they're not recorded...
 

Jake Bunce

XenForo moderator
Staff member
#4
Then it's possible Paypal failed to send the callback. That happens sometimes in which case you can manually upgrade the user in the Admin CP.
 
#7
I just started using this system, first I was setting it up to NO Recurring payments and worked fine. Now i have Recurring payments and they are not upgrading automatically.
AndreaMarucci is the same thing for you?
 
#8
Ok using Recurring payments I can see this error inside xf_user_upgrade_log table: Invalid business or receiver_email

I didn't enable Instant Payment Notifications (IPNs), so i guest that was my problem... fixed that and still waiting for PayPal to retry :p
 
#9
I think I am having the same proplem except mine is sorta working. I am getting payments. And some of my users are being upgraded some not. I have an IPN setup on a different domain. Can this be the reasons that all my users are not getting upgrades?
 
#10
In order to receive payments for User Upgrades, you must have a Premier or Business PayPal account. You must enable Instant Payment Notifications (IPNs) in PayPal under your Selling Preferences. You should enter a notification URL of [your Board URL]/payment_callback.php.

I did not do this
 

Jake Bunce

XenForo moderator
Staff member
#11
I think I am having the same proplem except mine is sorta working. I am getting payments. And some of my users are being upgraded some not. I have an IPN setup on a different domain. Can this be the reasons that all my users are not getting upgrades?
I am guessing the failed upgrades are incomplete payments. Sometimes you need to confirm receipt of incoming payments. It depends on how your Paypal account is configured.
 
#14
I have created a new paypal account. Also added the IPN url back to Xen. Do toy think this is whay my members are added to the upgrade list BUT not moved to the proper paid group?