• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Pre-Install Questions

#1
Hey,

So, I ran a small-ish forum for a little while, and have just chosen to fully reinstall it, for various reasons (primarily for a fresh re-launch and so I can minimise traffic).

Basically, I've seen a lot of stuff in other forums that I've really wanted, but I've never known how to get it. Firstly, I want the URL's to be like www.domain.com/boards/title or www.domain.com/threads/title. How do I do that? Is it something to do with a plugin, or is it something that needs to be changed within the files themselves?

I'm also hoping to run XenPorta on this forum, but I want XenPorta to be located at www.domain.com instead of www.domain.com/forum. Will it automatically do that, or do I need to do something?

Also, apologies if this is in the wrong place, wasn't too sure where to put it since I've no idea if it's actually pre-install or if I can install it and then worry about these things. I just want to make the forum as easy and logical as possible, and I feel that knowing what I have to do from the ground up helps a LOT.

Thanks!
 

Jake Bunce

XenForo moderator
Staff member
#2
You want friendly URLs:

http://xenforo.com/help/friendly-urls/

I'm also hoping to run XenPorta on this forum, but I want XenPorta to be located at www.domain.com instead of www.domain.com/forum. Will it automatically do that, or do I need to do something?
For that you should install XF in the web root. XenPorta has an option to take over the index route and assign the forum index to /forum. At that point /forum is a route and not a directory, but it appears the same in the URL. You can see an example of this on Jaxel's site (the author of XenPorta):

http://8wayrun.com/
 
#3
Ah yeah, I think I tried to do the friendly URLs last time, but I had no idea what to do when I got to the "Web Server Requirements and Setup" part, since I understood absolutely none of it.

By web root, you mean /www, right? Servers still confuse me, not sure how I managed to install it first time round haha!

EDIT: Actually, I think it's public_html...
 
#8
Hey, how would I find out which type I webserver I have (Apache, Nginx, etc)?

EDIT: No longer needed, turns out we got Apache :)