1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 PhpBB3 import problems

Discussion in 'Installation, Upgrade, and Import Support' started by Coolhaus, Apr 16, 2012.

  1. Coolhaus

    Coolhaus Member

    I have been developing a Xenforo site locally with no problems, working with an old database just for testing purposes. I am now setting up the live site and have successfully installed Xenforo and applied some basic customisations before making a backup of the database. There is no data in the forum yet just one admin user.

    I have a live site which is currently running phpBB3 and I now wish to import this database into XenForo using the built-in convertor. I have all the correct configuration details from the working config.php file – dbname, dbuser, password, tableprefix.

    It seems that whatever I enter in the Custom Avatar Path, & Attachment Path boxes just throws up an error, saying that these directories are not found. It must be something simple but I can't figure out why it isn't working. I would be happy to skip this step but it isn't an option in the XenForo ACP.

    My current phpBB is installed in: mysite.com/forum

    I have an .htacess file in the site root that I thought might be causing some issues (it is setup to redirect the sub-directory /forum to just mysite.com) so I have temporarily set that to 'rewrite off' but it hasn't helped :(

    Any thoughts greatly appreciated!
  2. BamaStangGuy

    BamaStangGuy Well-Known Member

    Are you putting in the full path to the phpBB folder directories?

    Example: /home/name/public_html/files
    sortlink likes this.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Enter .. before the path, like so: ../phpbb/forum/attachments
  4. Coolhaus

    Coolhaus Member

    Thanks for the replies I had been trying to enter the path from the phpBB3 site root /forum/images but strangely it didn't work for me with ../ either.
    However entering the absolute full path of the server /home/name/public_html/files as suggested does work. Thanks guys!

Share This Page