1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

phpbb import troubles

Discussion in 'Installation, Upgrade, and Import Support' started by Solidus, Mar 5, 2012.

  1. Solidus

    Solidus Well-Known Member

    Hello.

    I have phpbb installed at phpbb.domain.com/ and XenForo installed at phpbb.domain.com/xenforo/
    I am selecting 'Retain imported content IDs' as this is a new XF install.
    The database details I enter are correct with the prefix phpbb_ but I get these errors,

    • The attachments directory could not be found.
    • The avatars directory could not be found.
    I have tried the following,
    phpbb/images/avatars/upload
    /phpbb/images/avatars/upload
    and
    phpbb/files
    /phpbb/files
    Any help? Thank you.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try using a full server path to those directories. Something like:

    /home/yoursite/public_html/phpbb/images/avatars/upload

    Otherwise a relative path would have to be something like:

    ../images/avatars/upload
     
  3. Solidus

    Solidus Well-Known Member

    I've got it working, thanks.
     
  4. Solidus

    Solidus Well-Known Member

    Conversion completed, but nobody can login. Seems passwords were not imported, what went wrong?
    No avatars were imported either.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Was it a direct import from phpBB3? No double imports? Passwords should work.

    If avatars weren't imported then you must have given the wrong path. Or maybe the files themselves are missing. Maybe you are importing from an incomplete backup. There are many possibilities.
     
  6. Solidus

    Solidus Well-Known Member

    I converted first from MyBB to phpBB (passwords worked here), then from phpBB to Xenforo, where passwords stopped working.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    XenForo's phpBB importer recognizes phpBB's password format. Maybe phpBB was using a different authentication scheme for the myBB users. I don't know if phpBB supports this. Just guessing.

    Were avatars working in phpBB after the first import? Double imports require extra care to ensure that everything is working at each step.
     
  8. Solidus

    Solidus Well-Known Member

    Avatars were not imported to phpBB, that's not a big deal anyway.
    How can I check authentication schemes between the three? I still have them all installed.
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That requires examining the database to see how phpBB stores the passwords.

    Make sure your myBB passwords work in phpBB. If not then they simply won't work in XenForo.
     
  10. Solidus

    Solidus Well-Known Member

    MyBB passwords definitely work in phpBB, I've had several other confirm that.
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Assuming no problems with the import, phpBB may be using a different auth scheme to support myBB passwords. That might explain why they don't work in XenForo.
     
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  13. Solidus

    Solidus Well-Known Member

    I guess I have no choice but to instruct users to use the password reset.
     

Share This Page