Personally I'm not really fond of the current default setting: Not Set (No)
I would simply name it: Not Set
The No part makes it confusing, compared with the Never settings.
Second, Deny was the proper term, since you have the Allow settings.
My suggestion for the titles:
Not Set | Allow | Deny
On top of that, we have the tooltip telling us exactly what each permission set does for us.