1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Parse Error message

Discussion in 'Installation, Upgrade, and Import Support' started by Craig, Jan 2, 2011.

  1. Craig

    Craig Active Member

    Received the following error;

    Parse error: syntax error, unexpected $end in /home/wrxmod/public_html/library/XenForo/Template/Compiler/Admin.php on line 119
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is a file problem. You should re-upload the original files again, overwriting the existing files. Something must have gone wrong during the original upload. The default files shouldn't have syntax errors.
     
  3. Craig

    Craig Active Member

    ok i am redownloading the beta 5 version and starting over. hopefully this will fix the error
     
  4. Craig

    Craig Active Member

    I redownloaded beta version 5. sent it back over to my server, and again i received the following message;

    Parse error: syntax error, unexpected $end in /home/wrxmod/public_html/library/XenForo/Template/Compiler/Admin.php on line 119

    is there a way I can uninstall it all and start over?
     
  5. Craig

    Craig Active Member

    i am trying to loaded it into public_html.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You could delete all the files from the server and drop the tables from the database or delete the database and create a new one.

    The problem you're encountering though seems to indicate a problem with the files but it seems odd that you've experienced it twice now.
    Are you sure everything is FTPing correctly?
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Make sure you are uploading the files to the same location as the old files, thereby overwriting the old files. And look for any upload errors in your FTP client. FileZilla has a Failed transfers tab at the bottom.

    You can also try uploading just the file that is named in the error message:

    /home/wrxmod/public_html/library/XenForo/Template/Compiler/Admin.php

    It's the same process. Upload the original files and then run the install again.
     
  8. Craig

    Craig Active Member

    i am such a novice i doubt i would know.

    The program i use to upload is called Core FTP
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    As long as there are no errors reported by the FTP client then you have to assume everything uploaded correctly.

    If you use Firefox as a browser then you can always download FireFTP which I never have any problems with.
    http://fireftp.mozdev.org/
     

Share This Page