[OzzModz] XFOptimize - Minify, Preconnect & Preload

[OzzModz] XFOptimize - Minify, Preconnect & Preload [Paid] 1.0.2 Release Candidate 4

No permission to buy ($35.00)

arabia2

Member
I am waiting for your answer and help

I don't know why it is ignored

 

SatGuyScott

Active member
This was running great two versions ago.

The last update fixed the editor box issue, but users are still having issues seeing reactions and who liked things. I disabled it and it came back. As did my realtime Google Analytics map in my admin control panel. With this mod on the map does not show.

Before disabling it I tried turning everything off one setting at a time, nothing helped but disabling it.

Not complaining just reporting. :)
 

Abraham54

Well-known member
@Ozzy47 - on my testforum I had installed the newest version 1.0.2 Release Candidate 4.

And also Xon's Redis Cache.

They went along until I got white sitepage.
The server error report showed issues with the Redis Cache.
I removed in SRT de redisconfiguration from the config file and my testsite was live again.
I think there is a conflict between Redis Cache and your XF Optimize.
 

Abraham54

Well-known member
@Ozzy47 - what I wrote in message 3349, was an assumption.
The culprit was on my server, two of my sites used the same Redis Database.
This is repaired by my host.
Redis Cache and your Opimize work together now.
 

OakleyForum

Well-known member
Getting a slew of the below errors - across different users but seems to consistently be happening on one of our largest threads (22k+ pages).

Code:
ErrorException: [E_WARNING] Attempt to read property "message" on bool src/addons/Nulumia/XFOptimize/XF/Pub/View/Thread/View.php:28
Stack trace
#0 src/addons/Nulumia/XFOptimize/XF/Pub/View/Thread/View.php(28): XF::handlePhpError(2, '[E_WARNING] Att...', '/home/oakleyfo/...', 28)
#1 src/XF/Mvc/Renderer/AbstractRenderer.php(91): Nulumia\XFOptimize\XF\Pub\View\Thread\View->renderHtml()
#2 src/XF/Mvc/Renderer/Html.php(47): XF\Mvc\Renderer\AbstractRenderer->renderViewObject('XF:Thread\\View', 'public:thread_v...', Array)
#3 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#4 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(Nulumia\XFOptimize\XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#5 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(Nulumia\XFOptimize\XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#6 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#7 src/XF/App.php(2353): XF\Mvc\Dispatcher->run()
#8 src/XF.php(524): XF\App->run()
#9 index.php(20): XF::runApp('XF\\Pub\\App')
#10 {main}
 
Last edited:

El Porcharo

Well-known member
Just realized "by accident" that XFOptimize is bringing a sort of glitch on my footer.

I've set the extra_copyright phrase with a bit of HTML. Not only to style it a little, but also to add a script that keeps the current year up-to-date, so I don't have to edit the phrase manually every new year.

Seems this script is being blocked by XFOptimize, since the current year is not shown while the add-on is enabled.

Here's the script I'm using:

Code:
<script type="text/JavaScript">document.write(new Date().getFullYear());</script>

Any chance to exclude this from optimization? Or does anyone know a valid alternative to avoid to manually editing the current year every time?


Cheers!
 

Finexes

Well-known member
Or does anyone know a valid alternative to avoid to manually editing the current year every time?
I'm using something similar, you can achieve this without JS.
In PAGE_CONTAINER replace {{ phrase('extra_copyright') }} with {{ phrase('extra_copyright', {'year' : date($xf.time, 'Y')}) }}, afterwards you can edit the phrase extra_copyright and use {year} for the current year, e.g. © 2010 - {year} <a href="https://example.com">Example.com</a> All Rights reserved.
 

Frode789

Well-known member
Just to chime in, we use the standard style assets to link the images. CSS template code might look like:

Code:
background: url({{ asset('stylefolder') }}/xenforo/bg.png) no-repeat 0 0;

As an example.
Enabling Move blocking CSS to inline style did mess with the loading of my style.

Before:
View attachment 276439


After:
View attachment 276440

Bug on your end related to the setting or style related issue to take with Russ?
The console says "failed to load resources", and then pointing to the various elements missing from the style.
Based on Omni. (but customized version).
This issue is still there in the latest version.
Is there a fix for this planned in the near future? :)
Thanks for your work on this awesome addon!
 
Top