• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lack of interest Option to disable viewing youtube in posts

#1
I was kind of hoping that in the future there is the idea that users can disable the auto-embedding of youtube links (maybe just show as links) since sometimes FF struggles in I open a thread with 10 youtube video posts.

I know there is Flashblock, but I use youtube sometimes and found it obnoxious to have to double/triple click everytime to play a video.
 

Carlos

Well-known member
#2
This can be remedied by a toggle for another feature....

ACP > Options > Messages = Find this: "Auto-Embed Media Links"

If I were you, I'd click this checkbox: "Auto-embed media, and add a link to the content within this BB code"

That creates a youtube box, with a link underneath, for those users that don't want to click it 3 times, as your post says.

So, with this, you have all kinds of users using it. Those that can use the youtube box, and those that want to click to use youtube natively.
 
#3
I'm a bit confused. I understand everything up until this part:
for those users that don't want to click it 3 times, as your post says.
The reason for that is because if I use something like flashblock, I have to enable it everytime I want to view youtube videos (since if I disable it, I have to double click on the video just to watch it).

The thing is there are times were I do go through youtube videos, so I'd rather not have it blocked. The issue is with posts with like 3 youtube videos, my browser comes to a crawl trying to load them all.

The reason I didn't want to change the option is because I figured I'm in the minority for people with the issue, so I didn't want to punish everyone just because I don't like it.
 

Carlos

Well-known member
#4
I'm a bit confused. I understand everything up until this part
That was based on this:
I know there is Flashblock, but I use youtube sometimes and found it obnoxious to have to double/triple click everytime to play a video.
Moving on...
I was kind of hoping that in the future there is the idea that users can disable the auto-embedding of youtube links (maybe just show as links) since sometimes FF struggles in I open a thread with 10 youtube video posts.
In that area that I outlined in my post... There are three options.

The first one doesn't embed it automatically, so all "embedded" youtube posts are links. The second one is a standard toggle on xenForo. It's what I think you have turned on right now. But the third one is what you're looking for, since you're saying that you want everyone to be happy.
The reason for that is because if I use something like flashblock, I have to enable it everytime I want to view youtube videos (since if I disable it, I have to double click on the video just to watch it).
I'm not saying anything bad. I'm just trying to help you. :)
The thing is there are times were I do go through youtube videos, so I'd rather not have it blocked. The issue is with posts with like 3 youtube videos, my browser comes to a crawl trying to load them all.
Understandable. :)
The reason I didn't want to change the option is because I figured I'm in the minority for people with the issue, so I didn't want to punish everyone just because I don't like it.
That's what my suggestion is all about! :)
 
#5
Wait, either I'm not getting it or I'm completely stupid (betting on the second).
That creates a youtube box
That's what I was trying to eliminate. Here, for example, this is the post I tried to view before making this suggestion (mind you, this happens from time to time, so with it happening again I figured I'd make a request):

This thread has about 10-15 videos from various posts, this is it about 35 seconds into opening:



FF is still trying to load all those videos. What i was asking for is an option for users who don't want the box to appear, but just the link.

The reason I mentioned Flashblock is because people would probably say "Just get flashblock." I have it, but I also have a YT account cause I watch videos on youtube on the regular (on the youtube site, since I'm not forced to load 15 videos at once), and in order to block with FB, you have to block YT altogether. So then, when I go on my watching spree, and have to click 2-to-3 times on each video to play.
 

Carlos

Well-known member
#6
This is what the third option does:

xenVid.png
So, as you can see...If you're using FlashBlock (which I assume is a blocker for flash types such as youtube) you won't see that youtube box anymore, you will [only] see that link underneath.

I have this turned on at CODForums because I have gotten complaints from users about youtube playback on ipad and other devices. This was back on vB4, so when xenForo found a balance between two ideas, I turned this feature on, for both types of users.
 
#7
So, as you can see...If you're using FlashBlock (which I assume is a blocker for flash types such as youtube) you won't see that youtube box anymore, you will [only] see that link underneath.
But my issue is if I block it with Flashblock, I have to block youtube as a whole.

I don't want to block youtube, I just want an option so we don't have to see the youtube box on the forum posts.
 

Carlos

Well-known member
#8
But my issue is if I block it with Flashblock, I have to block youtube as a whole.
Even youtube links?
I don't want to block youtube, I just want an option so we don't have to see the youtube box on the forum posts.
It's a valid suggestion. I was trying to help with alternatives, as well.

Meh. I guess this thread didn't help... :(
 
#9
Even youtube links?

It's a valid suggestion. I was trying to help with alternatives, as well.

Meh. I guess this thread didn't help... :(
No, it doesn't block the links. But as I've stated, blocking Youtube so the box doesn't appear will make browsing the main Youtube site a headache (which I do occasionally). Which is why I was suggesting, an option so that video media only shows up as a link, and not the media box.

My main focus was so you wouldn't have to use flashblock with the only option of blocking Youtube as a whole, when you only want the youtube player blocked on one forum.

So its not that your suggestion hasnt quite helped, but its still not solving the problem I'm addressing (because a. The box is still there even with the link and b) Flashblocking youtube will make it so you have to click the link, be taken to youtube, where the video is once again block because you block youtube, meaning you have to double or triple click the youtube video to get it to play).
 

MagnusB

Well-known member
#10
There is an addon that enables permissions for bbcode, I would take a look at that and see if you can disallow your members from using the media or youtube bbcode.
 

MagnusB

Well-known member
#12
I am not sure what you want here.

A) Where it does not auto embed youtube links (i.e. embed the youtube player in the post)?
B) Where you want end user to uncheck "load youtube videos" or something like that in preferences, and then they view the posts only with youtube links?

B is not possible ATM, you would need an addon for that.
 
#13
A) Where it does not auto embed youtube links (i.e. embed the youtube player in the post)?
Thats what I'm trying to disable. An option to disable it from doing so on a user-by-user basis. Give people the option to not see auto-embed.

B) Where you want end user to uncheck "load youtube videos" or something like that in preferences, and then they view the posts only with youtube links?
YES.

Thats why I was making it a suggestion.
 

MagnusB

Well-known member
#14
I would think a better solution is to enable media embedding in overlays, that way users can just click a link and load the video. It is what I used to have, and I have not been able to look at it on xF as of yet :(

EDIT:
I just took a look at it, there doesn't seem a good way to enable it without an addon, I am afraid.
 

Rudy

Well-known member
#15
I was kind of hoping that in the future there is the idea that users can disable the auto-embedding of youtube links (maybe just show as links) since sometimes FF struggles in I open a thread with 10 youtube video posts.
B) Where you want end user to uncheck "load youtube videos" or something like that in preferences, and then they view the posts only with youtube links?
We currently need this functionality. Members on older computers literally cannot load pages easily when more than one or two videos are embedded. A shame this suggestion was mothballed... :(
 

Jeremy

Well-known member
#16
We currently need this functionality. Members on older computers literally cannot load pages easily when more than one or two videos are embedded. A shame this suggestion was mothballed... :(
I changed my YouTube embed to the following:
Code:
<iframe width="500" height="300" src="https://www.youtube.com/embed/{$id}?wmode=opaque&controls=2" frameborder="0" allowfullscreen></iframe>
The controls=2 loads the player only when the user initiates playback. I have a content/video heavy website and it struggled on the school computers where it really mattered. This really, really helped.
 

Rudy

Well-known member
#17
Oh wow...fantastic! So, that halts the pre-fetching of data. Cool. That is really where things get hung up. I'm going to have to try this out.

Thanks much @Jeremy!
 

Rudy

Well-known member
#19
Not specifically wanting to resurrect the dead thread, but lately on my sites, and another I browse, the embedded videos still work fine with this code (no preloading), but no longer display a thumbnail. Rather, the window is black instead. It doesn't bother me, but others seem to think something is wrong. I'm thinking YouTube changed something on their end, as I haven't touched my embed code since...well, since this thread. ;) It also is across multiple browsers, so it is not a problem with Chrome, or the OS, or even my specific location since others are reporting it.

Just a heads up in case anyone is wondering why the window is black. Although we still don't know exactly why...