• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue Opera "back" button and Facebook malfunctions

Rudy

Well-known member
#1
One of my admins pointed this out:


A weird thing started happening (either last night or this morning - can't remember which). I'm using Opera and when I am reading a thread and then want to back out it now takes three tries. I use the "hold right button/click left button" method in Opera instead of the back arrow button. The first click doesn't do anything, the second click doesn't do anything (but a "false" appears at the bottom of the page), and then the third click goes back. Using the back button seems to do the same thing (takes three tries).
The "false" appears where the Facebook code normally displays. Screenshot below.

Further info:


The version is 11.60 build 1185. I think this is from December. I don't remember seeing any updates recently.

No extensions enabled. Windows XP.
Confirmed in a later post: he has had the same Opera version for a couple of months, but this problem only started in the past couple of days. He has tried other XF forums, including this one, and has the same problem.

My guess is that something minor changed in the Facebook API, as XF and Opera are the constants.

I also know that when I had some advertising code on one of my old sites, the banners loaded in a way that I'd have to hit the back button a few times to actually hop back one page; I think what was happening there was that the browser was hopping back to the different portions of the same page that loaded at different times, rather than going back one actual page. And in the history (under the "back" button), you would see the actual previous page a couple of spots behind the current page, rather than being the next one. Hope that made sense...

Let me know if you need more info. Thanks!
 

Attachments

Rudy

Well-known member
#3
My guess: Opera is treating the individual elements loading (Google +1, Facebook widget, etc.) as individual pages rather than elements of the same page. That would explain why you have to hop back at least two or three times to get to the previous page. I had that issue with, I think, Firefox many years ago on one of my sites--it was due to how I was loading banner ads.

The only thing that has probably changed is Facebook. The version of Opera was a constant before and after this started happening. No telling what FB is doing; trying to nail down their API is like hitting a moving target.