• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Mysqli statement execute error : Query execution was interrupted

Divvens

Well-known member
#1
Another error that popped up randomly today. No idea what it is about, it has only occurred once, so should I ignore it?
PHP:
Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Query execution was interrupted - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Mac, Today at 11:04 AM

Stack Trace
#0 /home/orojacks/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/orojacks/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/orojacks/public_html/library/XenForo/Model/Thread.php(2088): Zend_Db_Adapter_Abstract->query('????INSERT DELA...', 66)
#3 /home/orojacks/public_html/library/XenForo/ControllerPublic/Thread.php(159): XenForo_Model_Thread->logThreadView(66)
#4 /home/orojacks/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Thread->actionIndex()
#5 /home/orojacks/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /home/orojacks/public_html/index.php(13): XenForo_FrontController->run()
#7 {main}

Request State
array(3) {
  ["url"] => string(47) "http://orojackson.com/threads/naruto.66/page-63"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Divvens

Well-known member
#3
Yes, you should be fine to ignore it. If it happens more often, the issue should be investigated then.
It happened again, but after a long gap, should I consider this "often"? It's the second time it's come up. Just for information, what could be the possible causes?

PHP:
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Query execution was interrupted - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Unknown Account, Today at 4:00 AM

Stack Trace
#0 /home/orojacks/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/orojacks/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/orojacks/public_html/library/XenForo/Model/Thread.php(2088): Zend_Db_Adapter_Abstract->query('????INSERT DELA...', 2615)
#3 /home/orojacks/public_html/library/XenForo/ControllerPublic/Thread.php(159): XenForo_Model_Thread->logThreadView(2615)
#4 /home/orojacks/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Thread->actionIndex()
#5 /home/orojacks/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /home/orojacks/public_html/index.php(13): XenForo_FrontController->run()
#7 {main}

Request State
array(3) {
  ["url"] => string(67) "http://orojackson.com/threads/follow-the-journey-of-one-piece.2615/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Mike

XenForo developer
Staff member
#4
You could try disabling "Enable Delayed Insert SQL Queries". In general, this simply appears to be MySQL killing the query for some reason. I'm not sure why this would happen though here.
 

Divvens

Well-known member
#5
These errors stopped showing up after upgrading to 1.2.4 (these errors never came before 1.2.3 as well). Just informing here if anyone else runs into similar issues in the future.
 

Divvens

Well-known member
#6
@Mike this error has resurfaced again in 1.3 (wouldn't get these errors in 1.2.4 & 1.2.5). Have got this error once until now after upgrading yesterday.

PHP:
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Query execution was interrupted - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Sammy, Today at 8:03 AM
Stack Trace
#0 /home/orojacks/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/orojacks/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/orojacks/public_html/library/XenForo/Model/Attachment.php(726): Zend_Db_Adapter_Abstract->query('????INSERT DELA...', 1494)
#3 /home/orojacks/public_html/library/XenForo/ControllerPublic/Attachment.php(46): XenForo_Model_Attachment->logAttachmentView(1494)
#4 /home/orojacks/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Attachment->actionIndex()
#5 /home/orojacks/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /home/orojacks/public_html/index.php(13): XenForo_FrontController->run()
#7 {main}
Request State
array(3) {
  ["url"] => string(51) "http://orojackson.com/attachments/kingdom-png.1494/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Mike

XenForo developer
Staff member
#7
XF can't trigger this error itself, so the comments from before still stand. If the delayed thread is being killed for some reason, that could trigger it.

Alternatively, you could potentially be running into a MySQL server bug, depending on what version you're running (5.5.8/9 seem to have some references to a related issue).