• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Mysqli statement execute error : Incorrect string value: '\xE8res" <-- please help?

#1
i am having a lot of errors about this and it is to do with characters that are not recognized i am not sure how to fix this...

Code:
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect string value: '\xE8res";...' for column 'server' at row 1 - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Unknown Account, Today at 5:09 AM
Stack Trace

#0 /home/unkn0wn/public_html/forums/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/unkn0wn/public_html/forums/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/unkn0wn/public_html/forums/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `sf...', Array)
#3 /home/unkn0wn/public_html/forums/library/XenForo/DataWriter.php(1612): Zend_Db_Adapter_Abstract->insert('sf_foolbothoney...', Array)
#4 /home/unkn0wn/public_html/forums/library/XenForo/DataWriter.php(1601): XenForo_DataWriter->_insert()
#5 /home/unkn0wn/public_html/forums/library/XenForo/DataWriter.php(1393): XenForo_DataWriter->_save()
#6 /home/unkn0wn/public_html/forums/library/Tac/FoolBotHoneyPot/ControllerPublic/Register.php(608): XenForo_DataWriter->save()
#7 /home/unkn0wn/public_html/forums/library/Nobita/AccountDetection/XenForo/ControllerPublic/Register.php(11): Tac_FoolBotHoneyPot_ControllerPublic_Register->actionRegister()
#8 /home/unkn0wn/public_html/forums/library/Tac/StopCountrySpam/ControllerPublic/Register.php(433): Nobita_AccountDetection_XenForo_ControllerPublic_Register->actionRegister()
#9 /home/unkn0wn/public_html/forums/library/XenForo/FrontController.php(347): Tac_StopCountrySpam_ControllerPublic_Register->actionRegister()
#10 /home/unkn0wn/public_html/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /home/unkn0wn/public_html/forums/index.php(13): XenForo_FrontController->run()
#12 {main}

Request State

array(3) {
  ["url"] => string(49) "http://portalcentric.net/forums/register/register"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(38) {
    ["4565752e7f208d5978"] => string(0) ""
    ["b3f8e52e7f208d5d5f"] => string(0) ""
    ["username"] => string(18) "abaf1b4e8d0e34afa3"
    ["d9c5852e7f208d51b6"] => string(0) ""
    ["6051352e7f208d59d6"] => string(8) "n4diir62"
    ["c615952e7f208d4f7e"] => string(0) ""
    ["4555c52e7f208d6958"] => string(0) ""
    ["8c23852e7f208d50f5"] => string(0) ""
    ["email"] => string(42) "x@819978f0-0b0f-11e2-892e-0800200c9a66.com"
    ["ca93d52e7f208d5c95"] => string(16) "N4DiiR-x@live.fr"
    ["43d6c52e7f208d4f1f"] => string(9) "Onelove62"
    ["a4e9a52e7f208d6359"] => string(9) "Onelove62"
    ["09f5052e7f208d527f"] => string(0) ""
    ["79f2d52e7f208d69a2"] => string(0) ""
    ["password"] => string(8) "********"
    ["password_confirm"] => string(8) "********"
    ["ee71a52e7f208d585e"] => string(0) ""
    ["b27d152e7f208d61d2"] => string(0) ""
    ["0d7d852e7f208d6011"] => string(0) ""
    ["2775952e7f208d52dd"] => string(0) ""
    ["dob_month"] => string(1) "6"
    ["dob_day"] => string(2) "16"
    ["dob_year"] => string(4) "1992"
    ["e609252e7f208d5573"] => string(0) ""
    ["ebf4652e7f208d5e25"] => string(0) ""
    ["63e7052e7f208d64d2"] => string(4) "male"
    ["gender"] => string(4) "male"
    ["ac84d52e7f208d67df"] => string(0) ""
    ["ca63652e7f208d5b03"] => string(14) "Pacific/Midway"
    ["eb52d52e7f208d5097"] => string(14) "Pacific/Midway"
    ["timezone"] => string(14) "Pacific/Midway"
    ["81ff052e7f208d5a9d"] => string(14) "Pacific/Midway"
    ["c793652e7f208d5033"] => string(16) "Europe/Amsterdam"
    ["public_uuid"] => string(25) "94689b84e4ce52e7f20f085d3"
    ["custom_img_captcha_response_field"] => string(5) "shoes"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "d71998c247599fd82b527af2b3d61f52"
  }
}
 

Brogan

XenForo moderator
Staff member
#2
Try disabling add-ons, specifically ones related to registration.

I see several listed in the trace.
 
#3
this only happened on some user registrations only those who use characters that my system cannot understand.

registrations work fine it is just some unicode/utf-8 code fails to work as a user name

i want it to not spit out an error for users that do this and instead say your username has characters that cannot be used on this site or something

and these add one's are a must as they protect me against spammers