• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Server issue My site is forbbiden for me.

#1
Hi today i wanted to check my inbox at my forum and got a java error.
After that i tryed to refresh the site and got this:

Code:
Forbidden
 
You don't have permission to access / on this server.
 
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
I think thats a bug.
 
#4
i get this:
Code:
Warning: Unknown: open_basedir restriction in effect. File(/www/sfcnr.uk.pn/forum/admin.php) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in Unknown on line 0
 
Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0
 
Fatal error: Unknown: Failed opening required '/www/sfcnr.uk.pn/forum/admin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in Unknown on line 0
 

CyclingTribe

Well-known member
#10
If you don't know how use the info you need to ask your host for assistance as this is something on your server that is restricting your access to your XF files.
 

Mopquill

Active member
#11
MrEdinLaw, it's obvious you're not particularly versed in this sort of thing. If you've changed anything in your configuration files recently, or moved the directory of your site, undo those changes. Basically, your forum directory is not within the open_basedir directory, which to simplify, controls which files your PHP scripts are allowed to access.

If you'd like, you can contact me via PM to let me into your server and I'll see about fixing it for you, telling you what was wrong and how to fix it next time. If you're not comfortable with that, then I recommend reading up on web server configuration. Assuming you're using Apache, you want to change the open_basedir line in your VirtualHosts from something like this:

Code:
php_admin_value open_basedir /home/:/usr/lib/php:/tmp
to something like this:

Code:
php_admin_value open_basedir /www/sfcnr.uk.pn:/usr/lib/php:/tmp
You should NOT include your entire /home directory in open_basedir. Feel free to add any other website's directory to its respective virtualhost.

My personal setup is to have /home/user/domains/example.com/pub/<content here> that way I can non-web-accessible content in example.com (that cannot be reached with the web root set to pub), but that can still be accessed by PHP if I need it to be. Good luck.
 

Mopquill

Active member
#12
It would seem our user here doesn't have (or doesn't know he has) any sort of control panel or account for changing settings. I'm with Clickfinity here, thinking he might be best off contacting his host.