1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Multi-Language web page in few seconds 1.0.1

Multi-Language web page in few seconds

  1. Gopala Subramanium

    Gopala Subramanium Active Member

    Gopala Subramanium submitted a new resource:

    Multi-Language web page in few seconds (version 1.0.0) - Multi-Language web page in few seconds

    Read more about this resource...
     
    Dinh Thanh and tramp010 like this.
  2. Edrondol

    Edrondol Well-Known Member

    I love this idea but the last time (in vB) I added something like this the translations were kinda laughable. Has Google translate improved enough to have good translations or is it still merely "serviceable"?
     
  3. Gopala Subramanium

    Gopala Subramanium Active Member

    Yes, for me it's working fine. I've checked it for our local languages.
     
  4. Edrondol

    Edrondol Well-Known Member

    Well, then. I'll give it a try!
     
  5. Edrondol

    Edrondol Well-Known Member

    Apparently this does things like Spanish very well. Finnish? Not so much. The quote from one of my Finnish users is: "Okay, tried it... and stopped it before the horrible translations would make my brain hemorrhage."

    So it works in that it translates, but it's translating into "Googlese" and tends to butcher the more exotic languages. I'll be leaving it on and this works just as advertised, but don't expect perfect translations.

    Oh, and I added this to my sidebar by making it a widget. I created a template called "translate" and then in the AdminCP -> Appearance -> Add Widget. I've attached a screenshot of how I set the widget. Works gangbusters.

    translate.png
     
  6. STORMS

    STORMS Active Member

    When I click to download, the link opens an attachment... link broken?
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Not exactly. You need to read the full Resource Description.

    There is no installer for this, you need to make the template edits yourself.
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    I've knocked this up.

    This is Gopala's code in an installable add-on.

    Gopala, feel free to update this resource with this add-on.
     

    Attached Files:

    TheVisitors and ArnyVee like this.
  9. Gopala Subramanium

    Gopala Subramanium Active Member

    Thanks for this, i'll update my post with this.
     
  10. Gopala Subramanium

    Gopala Subramanium Active Member

    Gopala Subramanium updated Multi-Language web page in few seconds with a new update entry:

    Multi-Language web page in few seconds [Widget]

    Read the rest of this update entry...
     
  11. nekregjt

    nekregjt Member

    Hello -

    I am attempting to install this add-on and I can't seem to get it to work. Any help would be appreciated. I completed the following step:

    1. Added the provided code to "logo_block"
    2. Added the provided code to "EXTRA.css"
    3. Uploaded the "upload" folder to the root directory
    4. Attempted to install the "addon-googleTranslate.xml" file through the Admin Control Panel. However when I click on Install Add-On I receive the message "Please enter a valid callback method."
    Thanks
     
  12. Chris D

    Chris D XenForo Developer Staff Member

    You've not followed the instructions correctly.

    You upload the contents of the upload folder (not the upload folder, just what is inside it).
     
  13. nekregjt

    nekregjt Member

    Yes I misunderstood that step. It's working perfectly now.
    Thank you!
     
    Chris D likes this.
  14. Gopala Subramanium

    Gopala Subramanium Active Member

    Thanks Chris for such a quick response :)
     
    Chris D likes this.
  15. Justin51982

    Justin51982 Member

    We are trying to get this installed correctly and are having a couple challenges.

    1st issue is when installing this add on to the header, it pushed everything down causing a bit of overlap. 2nd issue is every time the page loads in the very top you get the Google translate box that states "this page has been translated from english to german (or whatever language you choose), is there a way to stop that from popping up at the very top?

    Thanks for your help on these things, and if you want to see them in action, the site is www.trabantforums.com
     
  16. Gopala Subramanium

    Gopala Subramanium Active Member

    Hi, I visited your site, this is happening primarily because of the Header Logo. You need to increase the header tab height, goto AdminCP >> Appearance >> Styles >> Style Property >> Header and Navigation and increase the height till you get to the desired look. Hope this helps.
     
  17. Justin51982

    Justin51982 Member

    Thank you for responding and sorry for my delayed response. I went in and tried to fix it and we still had the same overlapping error even when we adjusted the header height and logo height.

    I am wondering if there may be an error we are missing in the script or somewhere else?

    Thanks.
     
  18. Echelon

    Echelon Active Member

    before installing the addon...anyone has any experience translating from dutch to us and what it looks like in terms of good translation?
     
  19. Chris D

    Chris D XenForo Developer Staff Member

    It uses Google Translate so just go to https://translate.google.com/ and paste in a Dutch website URL. That will translate the site for you. That'll be the same translation as this add-on provides.
     
    Echelon likes this.
  20. Echelon

    Echelon Active Member

    yes. that is stupid of me.......just need vacation. This translation is very bad from NL-US.

    as a matter of fact my site is already NL-US but im searching for a way where members can easily choose their language of choice...there's no such add on yet
     

Share This Page