• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Moving XenForo Forum to new host

#1
Hey Guys,

Loving XenForo.

I need to move my forum to another hosting provider, but not sure where to start. I have made the board in active, and will change the nameservers in due course.

Is there a way in the admin control panel to make a backup of the database? What steps do I need to take to move my forum to the new provider?

Thanks,

Michael
 

Brogan

XenForo moderator
Staff member
#2
How can I move my installation to a different host?
Backup the existing database and server files. Copy them to the new server and update the library/config.php file with the new database details. Lastly, update the Board URL in the ACP -> Options -> Basic Board Information, if it has changed.

http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180455

The database (SQL) backup can be done via cPanel/phpMyAdmin if you have that.

The server files can be backed up/copied using FTP.
 
#5
Hi Guys,

I've copied the files over, uploaded the sql database backup file and changed the config.php file but now i just get a blank page on where I should get the forum homepage.. what options do i have to debug this?

Also, I forgot to mention.. the system requirements don't mention weather I use Linux or Windows just that I need php and mysql5 which I do have on my windows server.. I know .htaccess doesn't work on IIS so do I need to do anything about this?

Thanks,

Michael
 

Brogan

XenForo moderator
Staff member
#6
You could try restarting the server - that is sometimes required depending on configuration.

Is the ACP available?
Try navigatiing directly to yourdomain.com/community/admin.php
 
#7
Thanks for your reply, Brogan.

I have restarted the website. Also, all pages are displaying a blank page. I have ran the xenforo_requirements.php script and that passes all tests.

Any other suggestions please?

Thanks,

Michael
 

Brogan

XenForo moderator
Staff member
#8
Can you post a link to the site?

Are there any errors in the Apache log?

Try enabling debug mode - that might shed some light on it.

How do I enable debug mode?
Edit the /library/config.php file to add the following line: $config['debug'] = true;
Note that it is not advised to run a live site with debug mode enabled due to the increased resources required.
 

DarkVodka

Formerly Wuebit
#10
Thanks again, Brogan..

It's running on IIS 7.5. I don't see any errors at all.. will try enabling some logging of some sort.

The website address is http://www.hummy.tv/forum/

Thanks,

Michael
You have messed up your config file I can see your username password datebase everything change it asap

The error is
An unexpected database error occurred. Please try again later.
<!-- Access denied for user ''@'localhost' (using password: NO) -->
From what I can see
 

Brogan

XenForo moderator
Staff member
#11
Looks like it's still resolving to the old site for me - I see a forum page with a message:
"Moving the forums to a new hosting provider. Back in a few days. - Michael"
 
#12
It seems to be working now. Thanks to Vodkaholic. I forgot to check source code of the blank page for the error messages..

Thank you Vodkaholic.

Problem I have now, when logging in its looking for "login/login" which I guess is Url Rewriting stuff.. how can i turn this off? Can i turn it off.. IIS doesn't use .htaccess does it?

Thanks,

Michael
 

DarkVodka

Formerly Wuebit
#13
Looks like it's still resolving to the old site for me - I see a forum page with a message:
"Moving the forums to a new hosting provider. Back in a few days. - Michael"
Well he changed / did something he should reply and say what he did as I could see everything (datebase name password username the works) than Mike should be told about it.
 

DarkVodka

Formerly Wuebit
#15
It seems to be working now. Thanks to Vodkaholic. I forgot to check source code of the blank page for the error messages..

Thank you Vodkaholic.

Problem I have now, when logging in its looking for "login/login" which I guess is Url Rewriting stuff.. how can i turn this off? Can i turn it off.. IIS doesn't use .htaccess does it?

Thanks,

Michael
Login/login is the right url
Ah in the admincp "nice urls" its called
 
#18
The original problem was due to the way I'd saved the config file - lost all linebreaks - which is now fixed.

The problem I have now is when trying to Login to the forum its trying to post the form to /login/login which doesn't physically exist so i guess this is url rewriting? Which normally uses .htaccess which doesn't work on IIS?

I'm unsure, otherwise..

Thanks,

Michael
 

DarkVodka

Formerly Wuebit
#19
The original problem was due to the way I'd saved the config file - lost all linebreaks - which is now fixed.

The problem I have now is when trying to Login to the forum its trying to post the form to /login/login which doesn't physically exist so i guess this is url rewriting? Which normally uses .htaccess which doesn't work on IIS?

I'm unsure, otherwise..

Thanks,

Michael
Login/login is the right url
Ah in the admincp "nice urls" its called
:p I edited me post