1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Moved hosts - Signup problems and login token issues.

Discussion in 'Troubleshooting and Problems' started by Adam K M, Jul 16, 2014.

  1. Adam K M

    Adam K M Active Member

    Hello,

    I recently switched hosts to a new forum host. I'm not entirely sure what I've done wrong, but in the error log I get the following error in the error_log. It appears to be spammed every one second:

    Code:
    [16-Jul-2014 10:43:00 America/Los_Angeles] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so: undefined symbol: output_globals in Unknown on line 0
    The two main problems that I've noticed so far are:

    signup.PNG
    New users trying to register this very strange error when submitting the form successfully. This happens to me as well when I try on a new browser.


    The second error is that in the admin panel is that it seems whenever I click a button or go to another area of the admin panel, it asks me to re-login. I'm guessing this is some sort of token error - I'm not even sure how to approach this.



    My error log is growing by the second, and I'm going to approach my hosts about this since I've had PDO problems with the current hosts before... however, I'm not sure if this current suhosin error is the cause of my actual xenforo worries.

    Any help is greatly appreciated.

    Thanks!
     
  2. Adam K M

    Adam K M Active Member

    Well this is awkward, the registration just worked for me, so this seems to be a very incosistent issue. Help/ideas please?
     
    Last edited: Jul 16, 2014
  3. Mike

    Mike XenForo Developer Staff Member

    That PHP error is related to a bad PHP configuration - it's loading a broken extension.

    If the registration worked when you tried again, then it's hard to suggest anything as any issue may well have been fixed already.
     
  4. Adam K M

    Adam K M Active Member

    hmm.

    Well, even if the sign up issue is no longer a matter now, we've still got this admin panel problem. The peculiar thing about it is that just as I am forced to constantly re-login from the Admin panel, some of my other members find themselves constantly being forced to re-login on the main forums itself. Is this some sort of token / DNS issue? I'm completely at a loss on how to fix this, and since it's with Xenforo itself, I don't predict that I'll be able to rely on my hosts to help me fix this problem. Any ideas?
     
  5. Mike

    Mike XenForo Developer Staff Member

    Are you behind a reverse proxy such as CloudFlare now? (https://support.cloudflare.com/hc/e...o-I-restore-original-visitor-IP-with-XenForo-)

    Try creating a PHP info file (phpinfo.php with <?php phpinfo(); ?> in it) and look for your IP address in the output. What is the name of the value it's in? Also, specifically, check the _SERVER[REMOTE_ADDR] value -- it's likely not your IP. If this is the case, then that will need to be sorted via a config.php edit, but we'd need to know what value the real IP is in.

    If that's not it, then disable any caching that you added to config.php, disable all add-ons using config.php, and reconfirm.
     
  6. Adam K M

    Adam K M Active Member

    How is it possible to tell if an add-on is using Config.php? My current hosts have disabled varnish cache for my forums, and when I check out the phpinfo(); command, I find my IP address perfectly fine. (At least the IP address that shows when I have a google search "what is my ip address".)

    My config.php is clean of any caching... it only contains access information for my database. Any more ideas? Would a upgrade from 1.3.0 to 1.3.4 be able to fix this? I'm doubtful, and didn't see anything in the update logs.

    Update: Again, I really need help with this token stuff.. I'm actually loosing the ability to make template edits from the admin panel because it gives me the error of not being logged in - then once I login again, it logs me out before I can even copy/paste the new changes into the template. (Meaning I get the not logged in error before I can even submit the changes)

    Does anyone have any ideas?
     
    Last edited: Jul 18, 2014
  7. Mike

    Mike XenForo Developer Staff Member

    Well, varnish is a reverse proxy, so if you just disabled that, there's a likely cause.

    However, the IP address we're looking for needs to be in a specific location (note my comment about REMOTE_ADDR). Your IP will be on the page, but if it's not in that field, issues like what you're seeing can occur.

    If you're still having the problem, the easiest option would be to link to your PHP info (either here or in a ticket if you prefer) and I can see if the IP data is correct.
     
  8. Adam K M

    Adam K M Active Member

    Sure thing. Here is my php info file.
     
  9. Mike

    Mike XenForo Developer Staff Member

    The IP does look ok. I did browse around the forums a bit and, looking at the headers, my session is being maintained. The ACP uses the same logic, it just doesn't have the "stay logged in" option which masks this issue. Are you still having problems?
     
  10. Adam K M

    Adam K M Active Member

    Yeah... the problem is still around. A few minutes ago, I was signed out of the Admin panel, and logging in again instantly brought me to the login screen for the admin panel again... almost as if I had never signed in, in the first place. I'm not sure if this is something my Hosts can resolve, but like you, I don't have enough information to approach them, after all, it looks a lot like a script problem or something.

    I've also got the problem happening on a fresh install of Xenforo on the same host - a development forums... you can take a look there if you want to.
     
  11. Mike

    Mike XenForo Developer Staff Member

    Well, I would need admin access, so please submit a ticket via your customer area so we can look into it.
     

Share This Page