Most Popular Tags

Most Popular Tags 1.0.5

No permission to download

Kevin

Well-known member
Add-on uninstalled and installed and again errors, very strange
ErrorException: Fatal Error: Class 'Eagle_MostPopularTags_ControllerPublic_Tags' not found -library/XenForo/FrontController.php:461
Did you update from an earlier version? If so, make sure that with the update that you have uploaded fresh copies of all of the PHP files to your server before upgrading the add-on XML in the ACP.

In earlier version the file used was {xf}/library/Eagle/MostPopularTags/ControllerPublic/MostPopularTags.php but it looks like with the recent version it has been renamed to {xf}/library/Eagle/MostPopularTags/ControllerPublic/Tags.php.

If you try upgrading from an older version using just the XML without also uploading the the updated PHP files then you'll get the error you are seeing.
 

Lindal_Oronar

Well-known member
Did you update from an earlier version? If so, make sure that with the update that you have uploaded fresh copies of all of the PHP files to your server before upgrading the add-on XML in the ACP.

In earlier version the file used was {xf}/library/Eagle/MostPopularTags/ControllerPublic/MostPopularTags.php but it looks like with the recent version it has been renamed to {xf}/library/Eagle/MostPopularTags/ControllerPublic/Tags.php.

If you try upgrading from an older version using just the XML without also uploading the the updated PHP files then you'll get the error you are seeing.
I did clean install, I have this add-on never used before.
 

Kevin

Well-known member
@Eagle have you tested the cache functionality? I see where you're doing a load from cache function but am not seeing where the cache is getting saved.
 

Eagle

Well-known member
Server Error ..@Eagle Can you help me

min(): Array must contain at least one element

XenForo_Application::handlePhpError()
min() in Eagle/MostPopularTags/Model/MostPopularTags.php at line 23
Eagle_MostPopularTags_Model_MostPopularTags->getListMostPopularTags() in Eagle/MostPopularTags/ControllerPublic/Tags.php at line 13
Eagle_MostPopularTags_ControllerPublic_Tags->actionIndex() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/public_html/index.php at line 13

I did clean install, I have this add-on never used before.

The fact there is no much difference tag function between XenForo Core Tag function but at least you can try it again now. I hope the problem solved now but if you still getting the same error, tell me here please. I have a question what's your PHP version?

@Eagle have you tested the cache functionality? I see where you're doing a load from cache function but am not seeing where the cache is getting saved.

Well try it again now Kevin thanks for this. I think it's ok now :p
 

TDUBS

Active member
I get this error on my index and my forum becomes inaccessible once I ran the update.

Code:
Datas must be string or set automatic_serialization = true

[code]
Zend_Cache::throwException() in Zend/Cache/Core.php at line 360
Zend_Cache_Core->save() in Eagle/MostPopularTags/Model/MostPopularTags.php at line 60
Eagle_MostPopularTags_Model_MostPopularTags->getListMostPopularTags() in Eagle/MostPopularTags/ControllerPublic/Tags.php at line 13
Eagle_MostPopularTags_ControllerPublic_Tags->actionIndex() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/nginx/domains/domain.com/public/index.php at line 13

Error:

Code:
Zend_Cache_Exception: Datas must be string or set automatic_serialization = true - library/Zend/Cache.php:209
Generated By: Tyler, 1 minute ago

Stack Trace

Code:
#0 /home/nginx/domains/domain.com/public/library/Zend/Cache/Core.php(360): Zend_Cache::throwException('Datas must be s...')
#1 /home/nginx/domains/domain.com/public/library/Eagle/MostPopularTags/Model/MostPopularTags.php(60): Zend_Cache_Core->save(Array, 'Eagle_MostPopul...', Array, 3600)
#2 /home/nginx/domains/domain.com/public/library/Eagle/MostPopularTags/ControllerPublic/Tags.php(13): Eagle_MostPopularTags_Model_MostPopularTags->getListMostPopularTags('12')
#3 /home/nginx/domains/domain.com/public/library/XenForo/FrontController.php(351): Eagle_MostPopularTags_ControllerPublic_Tags->actionIndex()
#4 /home/nginx/domains/domain.com/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#5 /home/nginx/domains/domain.com/public/index.php(13): XenForo_FrontController->run()
#6 {main}

Request State

Code:
array(3) {
  ["url"] => string(35) "http://www.domain.com/index.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}

 

Lindal_Oronar

Well-known member
The fact there is no much difference tag function between XenForo Core Tag function but at least you can try it again now. I hope the problem solved now but if you still getting the same error, tell me here please. I have a question what's your PHP version?
Thanks for the update @Eagle
When I installed the new version I got the same error but when I uploaded the files again it works :)
Is it possible to make a Xenporta2 widget?
 

Ivar

Member
Thanks for a great add-on.

I am trying to set the "Position:hook:ad_sidebar_top", but it does not seem to work... any kind of work-around available?

Thanks!
 

Freelancer

Well-known member
XF v1.5.5a
Most Popular Tags v1.0.5


Wanted to assign a specific tag to an RSS feed. Once I clicked to import the feed it came the following server error.

Code:
Server Error Log
Error Info
ErrorException: Division by zero - library/Eagle/MostPopularTags/Model/MostPopularTags.php:35
Generated By: Unknown Account, 1 minute ago
Stack Trace
#0 /var/www/clients/client180/web812/web/library/Eagle/MostPopularTags/Model/MostPopularTags.php(35): XenForo_Application::handlePhpError(2, 'Division by zer...', '/var/www/client...', 35, Array)
#1 /var/www/clients/client180/web812/web/library/Eagle/MostPopularTags/ControllerPublic/Tags.php(13): Eagle_MostPopularTags_Model_MostPopularTags->getListMostPopularTags('25')
#2 /var/www/clients/client180/web812/web/library/phc/LinkDirectory/Extend/XenForo/ControllerPublic/Forum.php(7): Eagle_MostPopularTags_ControllerPublic_Tags->actionIndex()
#3 /var/www/clients/client180/web812/web/library/NFLJ/AMS/XenForo/ControllerPublic/Forum.php(7): phc_LinkDirectory_Extend_XenForo_ControllerPublic_Forum->actionIndex()
#4 /var/www/clients/client180/web812/web/library/NFLJ/Showcase/XenForo/ControllerPublic/Forum.php(7): NFLJ_AMS_XenForo_ControllerPublic_Forum->actionIndex()
#5 /var/www/clients/client180/web812/web/library/XenForo/FrontController.php(351): NFLJ_Showcase_XenForo_ControllerPublic_Forum->actionIndex()
#6 /var/www/clients/client180/web812/web/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /var/www/clients/client180/web812/web/index.php(13): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
  ["url"] => string(32) "https://www.xxxxxxxxxxxxxxxxxxxx.com/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}


Once I deactivate the add-on, the error stops.
 

RAHSTYLES

Active member
Hey i using your tags and I like the javascript feature but it makes my site load slow.. and sometimes the tags first turn into regular words then it fully loads and does the javascript.. can you somehow work on the code to make it faster and more bug free?@eagle
 
Top